Bug 12649 - Early crash with 2.6.29-rc3
Early crash with 2.6.29-rc3
Status: CLOSED CODE_FIX
Product: ACPI
Classification: Unclassified
Component: Config-Other
All Linux
: P1 normal
Assigned To: drivers_pci@kernel-bugs.osdl.org
:
Depends on:
Blocks: 12398
  Show dependency treegraph
 
Reported: 2009-02-07 06:33 UTC by Rafael J. Wysocki
Modified: 2009-02-12 00:00 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.29-rc3
Tree: Mainline
Regression: Yes


Attachments
Output of acpidump on my laptop (182.63 KB, text/plain)
2009-02-10 14:59 UTC, Andrew McMillan
Details

Description Rafael J. Wysocki 2009-02-07 06:33:46 UTC
Subject    : Early crash with 2.6.29-rc3
Submitter  : Andrew McMillan <andrew@morphoss.com>
Date       : 2009-02-04 20:03
References : http://marc.info/?l=linux-kernel&m=123377840816097&w=4
Handled-By : Len Brown <lenb@kernel.org>

This entry is being used for tracking a regression from 2.6.28.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 ykzhao 2009-02-09 17:27:58 UTC
Hi, Andrew
    Will you please attach the output of acpidump?
    Thanks.
Comment 2 Andrew McMillan 2009-02-10 14:59:58 UTC
Created attachment 20186 [details]
Output of acpidump on my laptop
Comment 3 Lin Ming 2009-02-11 18:33:12 UTC
Andrew, 
please help to locate which line code causes the crash.
Build kernel with CONFIG_DEBUG_INFO=y, as below
menuconfig->General Setup->Optimize for size, disable this option
menuconfig->Kernel hacking->Compile the kernel with debug info, enable this option

reboot with this new kernel, then check EIP that causes the crash,
for example, 
EIP: 0060:[<c0441898>] EFLAGS: 00010217 CPU: 1

run addr2line to get the line of code,
addr2line c0441898 -e vmlinux
Comment 4 Andrew McMillan 2009-02-11 23:29:16 UTC
This problem appears to have been resolved in 2.6.29-rc4.  I have now built a kernel 2.6.29-rc4 with exactly the same configuration as earlier and it now boots and runs without this problem.
Comment 5 Zhang Rui 2009-02-12 00:00:26 UTC
good news. close this bug.
please re-open it if it can be reproduced in the upstream kernel again.

Note You need to log in before you can comment on or make changes to this bug.