Bug 12643 - suspend to disk does not power off
suspend to disk does not power off
Status: CLOSED DUPLICATE of bug 9258
Product: Power Management
Classification: Unclassified
Component: Hibernation/Suspend
All Linux
: P1 normal
Assigned To: power-management_other
:
Depends on:
Blocks: 7216
  Show dependency treegraph
 
Reported: 2009-02-06 14:41 UTC by Michal Suchanek
Modified: 2009-04-02 05:02 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.28.3
Tree: Mainline
Regression: No


Attachments
lspci output (10.27 KB, text/plain)
2009-02-07 06:28 UTC, Michal Suchanek
Details
lspci output (15.88 KB, text/plain)
2009-02-07 06:34 UTC, Michal Suchanek
Details

Description Michal Suchanek 2009-02-06 14:41:43 UTC
Latest working kernel version: none known
Earliest failing kernel version: 2.6.24.?
Distribution: Debian
Hardware Environment: x86_64 ASUS P5L-VM1394 board
Software Environment: Linux
Problem Description:

Recently software suspend does not work for me. However, I am not sure this is a Linux regression because I tried all Debian kernels installed (2.6.24, 2.6.25, 2.6.26), and at least 2.6.24 should be older than the problem. There is possibility that during an upgrade a "fixed" version of the kernel was installed. There is also a possibility that something I am not aware of has changed in the system causing s2d to fail.

Either way it must be something Linux does.

# poweroff

causes the system to power off normally

# reboot

causes the system to restart without ever powering off

# echo disk > /sys/power/state

causes the system to power off for a few seconds and then power back on going through the resume

in /sys/power/disk 'platform' is selected. Changing to 'shutdown' has no effect.

Powering off or suspending non-Linux systems works.

Steps to reproduce:

# echo disk > /sys/power/state
Comment 1 Rafael J. Wysocki 2009-02-06 15:47:37 UTC
Does it also happen if you unload the ehci-hcd module before hibernation?
Comment 2 Michal Suchanek 2009-02-06 18:21:46 UTC
no.

Unloading ehci_hcd fixes the problem. 

Earlier I had internal USB high-speed card reader attached at all times which I now removed because it malfunctioned and prevented the system from booting.

Thanks for the suggestion

I will blacklist ehci_hcd in my hibernation script.
Comment 3 Rafael J. Wysocki 2009-02-07 05:40:46 UTC
Please attach the output of lspci from your machine.
Comment 4 Michal Suchanek 2009-02-07 06:28:38 UTC
Created attachment 20152 [details]
lspci output
Comment 5 Michal Suchanek 2009-02-07 06:34:25 UTC
Created attachment 20153 [details]
lspci output
Comment 6 Zhang Rui 2009-03-18 20:07:31 UTC
I think the problem has already been fixed in the upstream kernel.
please try 2.6.28 and re-open this bug if the problem still exists.

*** This bug has been marked as a duplicate of bug 9258 ***
Comment 7 Michal Suchanek 2009-03-19 12:58:58 UTC
This was *reported* with 2.6.28.3.

Somebody at the other bug said it's broken with current git, too.
Comment 8 Rafael J. Wysocki 2009-03-19 13:52:50 UTC
That may be another bug with the same symptoms.

ehci_hcd on Intel chipsets tends to have this problem.  It hasn't been fixed, but the bug isn't new.
Comment 9 Michal Suchanek 2009-03-19 14:07:07 UTC
When they get a fix in I will check if it also fixes my case.

I don't like rebooting.
Comment 10 Rafael J. Wysocki 2009-03-19 14:10:55 UTC
Unfortunately, we don't know why it happens, so it's not likely there will be a fix any time soon.

Also, it's probably better to track this issue using one bug entry after all.

*** This bug has been marked as a duplicate of bug 9258 ***

Note You need to log in before you can comment on or make changes to this bug.