Bug 12642 - acer extensa 5220 doesn't resume after s2ram, when psmouse driver is loaded
acer extensa 5220 doesn't resume after s2ram, when psmouse driver is loaded
Status: CLOSED OBSOLETE
Product: Drivers
Classification: Unclassified
Component: Input Devices
All Linux
: P1 normal
Assigned To: drivers_input-devices
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-06 11:58 UTC by Dieter Bloms
Modified: 2012-05-30 12:53 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.29-rc3
Tree: Mainline
Regression: No


Attachments
output of acpidump (194.90 KB, application/octet-stream)
2009-02-06 11:59 UTC, Dieter Bloms
Details
output of dmesg (49.11 KB, application/octet-stream)
2009-02-06 12:00 UTC, Dieter Bloms
Details
output of dmidecode (7.11 KB, application/octet-stream)
2009-02-06 12:00 UTC, Dieter Bloms
Details
output of lspci -vvv (25.88 KB, application/octet-stream)
2009-02-06 12:00 UTC, Dieter Bloms
Details

Description Dieter Bloms 2009-02-06 11:58:52 UTC
Latest working kernel version:
Earliest failing kernel version:
Distribution: openSUSE 11.1
Hardware Environment: acer extensa 5220
Software Environment: 
Problem Description:
  my notebook goes fine in s2ram state, as long as I remove the psmouse driver  before s2ram.
When I don't removed the psmouse driver before s2ram, then
the notebook turns off immediately when I resume.
I don't know how to debug this, if you can tell me a way to give you more
information, I will do it.
I will add some stuff like acpidump, dmidecode, ...
The dmesg is from s2ram and resume while unload the psmouse driver, because when I don't remove it, it turns off and
I can't get the dmesg output.


Steps to reproduce:

don't rmmod psmouse and the system doesn't come up after s2ram
Comment 1 Dieter Bloms 2009-02-06 11:59:36 UTC
Created attachment 20136 [details]
output of acpidump
Comment 2 Dieter Bloms 2009-02-06 12:00:02 UTC
Created attachment 20137 [details]
output of dmesg
Comment 3 Dieter Bloms 2009-02-06 12:00:24 UTC
Created attachment 20138 [details]
output of dmidecode
Comment 4 Dieter Bloms 2009-02-06 12:00:54 UTC
Created attachment 20139 [details]
output of lspci -vvv
Comment 5 Alan 2012-05-30 12:53:01 UTC
Closing as obsolete, if this is still present in more recent kernels please re-open/update the bug. Thanks

Note You need to log in before you can comment on or make changes to this bug.