Bug 12639 - Reversed mac address with MSI K7N2's integrated nic + forcedeth
Reversed mac address with MSI K7N2's integrated nic + forcedeth
Status: RESOLVED DUPLICATE of bug 12614
Product: Drivers
Classification: Unclassified
Component: Network
All Linux
: P1 normal
Assigned To: Ayaz Abdulla
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-06 09:30 UTC by Ari Jasberg
Modified: 2009-02-27 00:24 UTC (History)
0 users

See Also:
Kernel Version: 2.6.28.3
Tree: Mainline
Regression: ---


Attachments

Description Ari Jasberg 2009-02-06 09:30:08 UTC
Latest working kernel version: unknown

Earliest failing kernel version: unknown

Distribution: Mythbuntu 8.10

Hardware Environment: MSI K7N2 + ASUS Geforce N7600GS Silent

lspci

00:00.0 Host bridge: nVidia Corporation nForce2 IGP2 (rev c1)
00:00.1 RAM memory: nVidia Corporation nForce2 Memory Controller 1 (rev c1)
00:00.2 RAM memory: nVidia Corporation nForce2 Memory Controller 4 (rev c1)
00:00.3 RAM memory: nVidia Corporation nForce2 Memory Controller 3 (rev c1)
00:00.4 RAM memory: nVidia Corporation nForce2 Memory Controller 2 (rev c1)
00:00.5 RAM memory: nVidia Corporation nForce2 Memory Controller 5 (rev c1)
00:01.0 ISA bridge: nVidia Corporation nForce2 ISA Bridge (rev a4)
00:01.1 SMBus: nVidia Corporation nForce2 SMBus (MCP) (rev a2)
00:02.0 USB Controller: nVidia Corporation nForce2 USB Controller (rev a4)
00:02.1 USB Controller: nVidia Corporation nForce2 USB Controller (rev a4)
00:02.2 USB Controller: nVidia Corporation nForce2 USB Controller (rev a4)
00:04.0 Ethernet controller: nVidia Corporation nForce2 Ethernet Controller (rev a1)
00:06.0 Multimedia audio controller: nVidia Corporation nForce2 AC97 Audio Controler (MCP) (rev a1)
00:08.0 PCI bridge: nVidia Corporation nForce2 External PCI Bridge (rev a3)
00:09.0 IDE interface: nVidia Corporation nForce2 IDE (rev a2)
00:1e.0 PCI bridge: nVidia Corporation nForce2 AGP (rev c1)
02:00.0 VGA compatible controller: nVidia Corporation G73 [GeForce 7600 GS] (rev a2)

Software Environment: Mythbuntu 8.10  + kernel 2.6.28.3

lsmod

af_packet              25344  2 
sco                    18180  2 
bridge                 56212  0 
stp                    10756  1 bridge
rfcomm                 43280  0 
bnep                   20352  2 
l2cap                  29952  6 rfcomm,bnep
bluetooth              61412  6 sco,rfcomm,bnep,l2cap
ppdev                  15620  0 
ipv6                  258420  29 
container              11648  0 
sbs                    19464  0 
sbshc                  13440  1 sbs
video                  24976  0 
output                 11136  1 video
wmi                    14760  0 
rfkill                 19020  0 
input_polldev          12040  0 
pci_slot               12680  0 
battery                18436  0 
iptable_filter         11008  0 
ip_tables              19472  1 iptable_filter
x_tables               23300  1 ip_tables
xfs                   552488  1 
ac                     12420  0 
lp                     17156  0 
dvb_usb_dib0700        42248  13 
dib7000p               24584  2 dvb_usb_dib0700
dib7000m               22276  1 dvb_usb_dib0700
dvb_usb                24588  1 dvb_usb_dib0700
evdev                  17696  6 
dvb_core               91904  1 dvb_usb
dib3000mc              20616  1 dvb_usb_dib0700
dibx000_common         11780  3 dib7000p,dib7000m,dib3000mc
dib0070                15748  2 dvb_usb_dib0700
psmouse                49680  0 
serio_raw              13572  0 
snd_intel8x0           37660  1 
snd_ac97_codec        112164  1 snd_intel8x0
ac97_bus                9984  1 snd_ac97_codec
snd_pcm_oss            46208  0 
snd_mixer_oss          22656  1 snd_pcm_oss
snd_pcm                82692  3 snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_seq_dummy          11012  0 
parport_pc             40100  1 
parport                42476  3 ppdev,lp,parport_pc
pcspkr                 10752  0 
snd_seq_oss            38016  0 
snd_seq_midi           14464  0 
snd_rawmidi            29696  1 snd_seq_midi
snd_seq_midi_event     15360  2 snd_seq_oss,snd_seq_midi
snd_seq                57008  6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer              29320  2 snd_pcm,snd_seq
i2c_nforce2            15108  0 
snd_seq_device         15244  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
nvidia_agp             14748  1 
button                 14352  0 
snd                    62500  12 snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
i2c_core               32020  8 dvb_usb_dib0700,dib7000p,dib7000m,dvb_usb,dib3000mc,dibx000_common,dib0070,i2c_nforce2
agpgart                42440  1 nvidia_agp
shpchp                 40340  0 
pci_hotplug            34720  1 shpchp
soundcore              15456  1 snd
snd_page_alloc         17160  2 snd_intel8x0,snd_pcm
ext3                  133256  1 
jbd                    55188  1 ext3
mbcache                16132  1 ext3
sr_mod                 22212  0 
cdrom                  42784  1 sr_mod
sd_mod                 41880  4 
crc_t10dif             10112  1 sd_mod
sg                     36404  0 
pata_amd               18820  3 
ata_generic            13060  0 
pata_acpi              12416  0 
libata                179872  3 pata_amd,ata_generic,pata_acpi
scsi_mod              158996  4 sr_mod,sd_mod,sg,libata
ehci_hcd               43276  0 
ohci_hcd               32016  0 
forcedeth              61840  0 
usbcore               152464  5 dvb_usb_dib0700,dvb_usb,ehci_hcd,ohci_hcd
thermal                23580  0 
processor              48812  1 thermal
fan                    12676  0 
fuse                   59548  1 

Xorg.conf uses the open source graphics driver "nv".


Problem Description: After shutting down mythbuntu, I have to reverse the mac address of the integrated nic to wake up my pc with wol.

Steps to reproduce:

1) boot into linux
2) shutdown linux
3) on my second pc,
  a) entering a command wakeonlan 00:00:00:00:00:XX:YY (the real mac) won't wake up the first pc,
  b) but wakeonlan YY:XX:00:00:00:00 will wake it up

On the other hand, if a power on the first pc, and immediately power it off by using the power button, it will wake up with the real, non-reversed,  mac address.

The same problem occures at least with the kernels 2.6.27-7-generic, 2.6.27-11-generic that are distributed with mythbuntu 8.10.
Comment 1 Philipp Matthias Hahn 2009-02-26 00:52:18 UTC
Same as #12614 ?
Comment 2 Ari Jasberg 2009-02-27 00:24:16 UTC
Even though I dont have time to test this throughly at the moment, my case seems to have the same symptoms as #12614. I did similar
structured testing and the result is identical. I applied the patch http://marc.info/?l=linux-kernel&m=123411195117835&w=4 on 2.6.28.3 and it did the work: I can use the correct MAC address both after shutdown and after suspend.


*** This bug has been marked as a duplicate of bug 12614 ***

Note You need to log in before you can comment on or make changes to this bug.