Bug 12629 - EXT3-fs error (device dm-1): ext3_new_block: Allocating block in system zone
Summary: EXT3-fs error (device dm-1): ext3_new_block: Allocating block in system zone
Status: CLOSED OBSOLETE
Alias: None
Product: File System
Classification: Unclassified
Component: ext3 (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: fs_ext3@kernel-bugs.osdl.org
URL:
Keywords:
: 12630 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-02-03 23:37 UTC by Juris Krumins
Modified: 2012-05-30 12:49 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.28.2
Tree: Mainline
Regression: No


Attachments

Description Juris Krumins 2009-02-03 23:37:03 UTC
I'm experiencing problem with fs, reflected by the following errors:

...
EXT3-fs error (device dm-1): ext3_new_block: Allocating block in system zone - blocks from 537690639, length 1
EXT3-fs error (device dm-1): ext3_new_block: Allocating block in system zone - blocks from 537690640, length 1
EXT3-fs error (device dm-1): ext3_new_block: Allocating block in system zone - blocks from 537690641, length 1
EXT3-fs error (device dm-1): ext3_new_block: Allocating block in system zone - blocks from 537690642, length 1
EXT3-fs error (device dm-1): ext3_new_block: Allocating block in system zone - blocks from 537690643, length 1
EXT3-fs error (device dm-1): ext3_new_block: Allocating block in system zone - blocks from 537690644, length 1
EXT3-fs error (device dm-1): ext3_new_block: Allocating block in system zone - blocks from 537690645, length 1
EXT3-fs error (device dm-1): ext3_new_block: Allocating block in system zone - blocks from 537690646, length 1
EXT3-fs error (device dm-1): ext3_new_block: Allocating block in system zone - blocks from 537690647, length 1
...

Distribution  - CentOS 5.2
Hardware used - IBM x3650 with ServerRAID10K raid controller and EXP3000 disk bay (12 SATA disks, RAID0. Total LD size ~8TB).
Tested with different default centos kernels (kernel-2.6.18-92.el5, kernel-2.6.18-92.1.22.el5), the same
error. Tested also with custom 2.6.28.2 kernel and different FS flags, no changes.
Hardware used - IBM x3650 with ServerRAID10K raid controller and EXP3000 disk bay (12 SATA disks, RAID0. Total LD size ~8TB).
Right now running test on 2.6.28.2 with different FS flags, partition sizes and so on. More that that, dm-crypt module is used
for this partition. But I think it's not dm-crypt related issue.


Right now I'm trying to update mu e2fsprogs utulities and run tests. Still running and it's seems like FS, created with new e2fsprogs,
 looks more stable.
Comment 1 Juris Krumins 2009-02-04 01:08:46 UTC
*** Bug 12630 has been marked as a duplicate of this bug. ***
Comment 2 Alan 2012-05-30 12:48:53 UTC
Closing as obsolete, please re-open if seen with recent kernels.

Note You need to log in before you can comment on or make changes to this bug.