Bug 12618 - hackbench [pthread mode] regression with 2.6.29-rc3
Summary: hackbench [pthread mode] regression with 2.6.29-rc3
Status: CLOSED CODE_FIX
Alias: None
Product: Process Management
Classification: Unclassified
Component: Other (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: process_other
URL:
Keywords:
Depends on:
Blocks: 12398
  Show dependency tree
 
Reported: 2009-02-01 16:28 UTC by Rafael J. Wysocki
Modified: 2009-02-25 15:00 UTC (History)
0 users

See Also:
Kernel Version: 2.6.29-rc3
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-02-01 16:28:22 UTC
Subject    : hackbench [pthread mode] regression with 2.6.29-rc3
Submitter  : "Zhang, Yanmin" <yanmin_zhang@linux.intel.com>
Date       : 2009-02-01 7:30
References : http://marc.info/?l=linux-kernel&m=123347347726527&w=4
Handled-By : Peter Zijlstra <peterz@infradead.org>
Notify-Also : Ingo Molnar <mingo@elte.hu>

This entry is being used for tracking a regression from 2.6.28.  Please don't
close it until the problem is fixed in the mainline.

Caused by:

commit 490dea45d00f01847ebebd007685d564aaf2cd98
Author: Peter Zijlstra <peterz@infradead.org>
Date:   Mon Nov 24 17:06:57 2008 +0100

    itimers: remove the per-cpu-ish-ness

    Signed-off-by: Peter Zijlstra <peterz@infradead.org>
    Signed-off-by: Ingo Molnar <mingo@elte.hu>

First-Bad-Commit : 490dea45d00f01847ebebd007685d564aaf2cd98
Comment 2 Rafael J. Wysocki 2009-02-25 15:00:15 UTC
On Tuesday 24 February 2009, Ingo Molnar wrote:
> 
> * Zhang, Yanmin <yanmin_zhang@linux.intel.com> wrote:
> 
> > On Tue, 2009-02-24 at 09:48 +0100, Peter Zijlstra wrote:
> > > On Mon, 2009-02-23 at 22:48 +0100, Rafael J. Wysocki wrote:
> > > > This message has been generated automatically as a part of a report
> > > > of recent regressions.
> > > > 
> > > > The following bug entry is on the current list of known regressions
> > > > from 2.6.28.  Please verify if it still should be listed and let me
> know
> > > > (either way).
> > > > 
> > > > 
> > > > Bug-Entry       : http://bugzilla.kernel.org/show_bug.cgi?id=12618
> > > > Subject         : hackbench [pthread mode] regression with 2.6.29-rc3
> > > > Submitter       : Zhang, Yanmin <yanmin_zhang@linux.intel.com>
> > > > Date            : 2009-02-01 7:30 (23 days old)
> > > > First-Bad-Commit:
> http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=490dea45d00f01847ebebd007685d564aaf2cd98
> > > > References      :
> http://marc.info/?l=linux-kernel&m=123347347726527&w=4
> > > > Handled-By      : Peter Zijlstra <peterz@infradead.org>
> > > > Patch           :
> http://marc.info/?l=linux-kernel&m=123383366122146&w=4
> > > >                  
> http://marc.info/?l=linux-kernel&m=123383366222152&w=4
> > > 
> > > 
> > > I thought this was all upstream by now,
> > Yes.
> > 
> > >  Yanmin, are we still seeing some
> > > badness?
> > No. Pls. close the bug report.
> 
> for the record, fixed by:
> 
>  3fccfd6: timers: split process wide cpu clocks/timers, fix

Note You need to log in before you can comment on or make changes to this bug.