Bug 12617 - unable to compile e100 firmware into kernel
unable to compile e100 firmware into kernel
Status: CLOSED DOCUMENTED
Product: Other
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: other_other
:
: 12507 (view as bug list)
Depends on:
Blocks: 12398
  Show dependency treegraph
 
Reported: 2009-02-01 16:23 UTC by Rafael J. Wysocki
Modified: 2009-02-25 14:57 UTC (History)
0 users

See Also:
Kernel Version: 2.6.29-rc
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-02-01 16:23:13 UTC
Subject    : 2.6.29-rc: unable to compile e100 firmware into kernel
Submitter  : Andrey Borzenkov <arvidjaar@mail.ru>
Date       : 2009-01-31 15:59
References : http://marc.info/?l=linux-kernel&m=123341764915181&w=4
Notify-Also : Jesse Brandeburg <jesse.brandeburg@gmail.com>
Notify-Also : David Woodhouse <dwmw2@infradead.org>

This entry is being used for tracking a regression from 2.6.28.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2009-02-04 04:35:51 UTC
*** Bug 12507 has been marked as a duplicate of this bug. ***
Comment 2 Rafael J. Wysocki 2009-02-15 13:07:56 UTC
On Sunday 15 February 2009, Andrey Borzenkov wrote:
> On 15 of February 2009 20:38:15 David Woodhouse wrote:
> > On Sat, 2009-02-14 at 21:38 +0100, Rafael J. Wysocki wrote:
> > >  This message has been generated automatically as a part of a
> > > report of recent regressions.
> > >
> > > The following bug entry is on the current list of known regressions
> > > from 2.6.28.  Please verify if it still should be listed and let me
> > > know (either way).
> > >
> > >
> > > Bug-Entry       : http://bugzilla.kernel.org/show_bug.cgi?id=12617
> > > Subject         : unable to compile e100 firmware into kernel
> > > Submitter       : Andrey Borzenkov <arvidjaar@mail.ru>
> > > Date            : 2009-01-31 15:59 (15 days old)
> > > References      :
> > > http://marc.info/?l=linux-kernel&m=123341764915181&w=4
> >
> > I thought this was resolved?
> 
> I guess it has to be closed. This was caused by config options mismatch 
> and I do not see how we can programmatically express "this device could 
> be required before any (even early) user space is available, so make 
> sure everything that this device needs is built in".
> 
> One possibility is following:
> 
> --- drivers/base/Kconfig.orig 2009-01-17 14:46:28.000000000 +0300
> +++ drivers/base/Kconfig        2009-02-15 22:57:02.000000000 +0300
> @@ -37,7 +37,7 @@ config FW_LOADER
> 
>  config FIRMWARE_IN_KERNEL
>         bool "Include in-kernel firmware blobs in kernel binary"
> -       depends on FW_LOADER
> +       depends on FW_LOADER = y
>         default y
>         help
>           The kernel source tree includes a number of firmware 'blobs'
> 
> On assumption that compiling firmware in kernel makes no sense as long 
> as kernel does not even have facility to actually access it.


Note You need to log in before you can comment on or make changes to this bug.