Bug 12615 - boot hangs while bringing up gianfar ethernet
boot hangs while bringing up gianfar ethernet
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Network
All Linux
: P1 normal
Assigned To: Jeff Garzik
:
Depends on:
Blocks: 12398
  Show dependency treegraph
 
Reported: 2009-02-01 16:09 UTC by Rafael J. Wysocki
Modified: 2009-02-16 13:11 UTC (History)
0 users

See Also:
Kernel Version: commit 8c7396aebb68994c0519e438eecdf4d5fa9c7844
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-02-01 16:09:01 UTC
Subject    : [BUG BISECTED] boot hangs while bringing up gianfar ethernet
Submitter  : Ira Snyder <iws@ovro.caltech.edu>
Date       : 2009-01-29 19:41
References : http://marc.info/?l=linux-kernel&m=123325817201665&w=4
Notify-Also : Peter Korsgaard <jacmet@sunsite.dk>

This entry is being used for tracking a regression from 2.6.28.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2009-02-04 17:23:55 UTC
On Wednesday 04 February 2009, Ira Snyder wrote:
> On Wed, Feb 04, 2009 at 11:24:08AM +0100, Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> > 
> > The following bug entry is on the current list of known regressions
> > from 2.6.28.  Please verify if it still should be listed and let me know
> > (either way).
> > 
> > 
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=12615
> > Subject		: boot hangs while bringing up gianfar ethernet
> > Submitter	: Ira Snyder <iws@ovro.caltech.edu>
> > Date		: 2009-01-29 19:41 (7 days old)
> > References	: http://marc.info/?l=linux-kernel&m=123325817201665&w=4
> > 
> > 
> 
> Tested this morning with Linux version 2.6.29-rc3-00563-g37f752c, and I
> still see the same behavior.

Comment 2 Rafael J. Wysocki 2009-02-15 13:06:24 UTC
On Sunday 15 February 2009, Peter Korsgaard wrote:
> >>>>> "Rafael" == Rafael J Wysocki <rjw@sisk.pl> writes:
> 
>  Rafael> This message has been generated automatically as a part of a report
>  Rafael> of recent regressions.
> 
>  Rafael> The following bug entry is on the current list of known
>  Rafael> regressions from 2.6.28.  Please verify if it still should be
>  Rafael> listed and let me know (either way).
> 
> As already mentioned, the fix works for me so I think this can be
> closed.
> 
>  Rafael> Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=12615
>  Rafael> Subject		: boot hangs while bringing up gianfar ethernet

Comment 3 Rafael J. Wysocki 2009-02-16 13:10:36 UTC
On Monday 16 February 2009, Jarek Poplawski wrote:
> On 14-02-2009 21:35, Rafael J. Wysocki wrote:
> > This message contains a list of some regressions from 2.6.28, for which there
> > are no fixes in the mainline I know of.  If any of them have been fixed already,
> > please let me know.
> ...
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=12615
> > Subject		: boot hangs while bringing up gianfar ethernet
> > Submitter	: Ira Snyder <iws@ovro.caltech.edu>
> > Date		: 2009-01-29 19:41 (17 days old)
> > References	: http://marc.info/?l=linux-kernel&m=123325817201665&w=4
> 
> Fixed by:
> commit	8707bdd48ab705a459ac1b12014075a139d1d4f9
> gianfar: Fix boot hangs while bringing up gianfar ethernet
> http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=8707bdd48ab705a459ac1b12014075a139d1d4f9


Note You need to log in before you can comment on or make changes to this bug.