Bug 12613 - [Suspend regression][DRM, RADEON]
[Suspend regression][DRM, RADEON]
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel)
All Linux
: P1 normal
Assigned To: drivers_video-dri
:
Depends on:
Blocks: 7216 12398
  Show dependency treegraph
 
Reported: 2009-02-01 15:56 UTC by Rafael J. Wysocki
Modified: 2009-02-25 14:56 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.29-rc3
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-02-01 15:56:44 UTC
Subject    : [2.6.29-rc3][Suspend regression][DRM, RADEON]
Submitter  : etienne <etienne.basset@numericable.fr>
Date       : 2009-01-28 22:00
References : http://marc.info/?l=linux-kernel&m=123318030419558&w=4

This entry is being used for tracking a regression from 2.6.28.  Please don't
close it until the problem is fixed in the mainline.

Reportedly caused by:

commit a9d51a5ad1154b5b20add1e8d30a5564f8aabbe9
Author: Dave Airlie <airlied@linux.ie>
Date:   Sun Dec 7 12:02:21 2008 +1000

    drm: reorganise start and load.

    Make sure we have the primary node so the device can add maps.

    Signed-off-by: Dave Airlie <airlied@redhat.com>

First-Bad-Commit : a9d51a5ad1154b5b20add1e8d30a5564f8aabbe9
Comment 1 Rafael J. Wysocki 2009-02-01 15:59:36 UTC
References : http://marc.info/?l=linux-kernel&m=123334865404574&w=4
Notify-Also : Soeren Sonnenburg <kernel@nn7.de>
Comment 2 Rafael J. Wysocki 2009-02-04 17:19:15 UTC
On Wednesday 04 February 2009, etienne wrote:
> Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> >
> > The following bug entry is on the current list of known regressions
> > from 2.6.28.  Please verify if it still should be listed and let me know
> > (either way).
> >
> >
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=12613
> > Subject		: [Suspend regression][DRM, RADEON]
> > Submitter	: etienne <etienne.basset@numericable.fr>
> > Date		: 2009-01-28 22:00 (8 days old)
> > First-Bad-Commit: http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=a9d51a5ad1154b5b20add1e8d30a5564f8aabbe9
> > References	: http://marc.info/?l=linux-kernel&m=123318030419558&w=4
> > 		  http://marc.info/?l=linux-kernel&m=123334865404574&w=4
> >
> >
> >   
> hello,
> 
> yes it is still here with today's git

Comment 3 Rafael J. Wysocki 2009-02-08 13:01:36 UTC
First-Bad-Commit : a9d51a5ad1154b5b20add1e8d30a5564f8aabbe9
Comment 4 Rafael J. Wysocki 2009-02-08 14:11:42 UTC
On Sunday 08 February 2009, etienne wrote:
> Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> >
> > The following bug entry is on the current list of known regressions
> > from 2.6.28.  Please verify if it still should be listed and let me know
> > (either way).
> >
> >
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=12613
> > Subject		: [Suspend regression][DRM, RADEON]
> >   
> hello,
> yes it's still present in -rc4
> But I noticed that when I switch off KDE4.2 desktop effects, suspend to 
> ram is 100% reliable with 2.6.29-rc4
> With 2.6.28, STR is 100% reliable with or without desktop effects

Comment 5 Rafael J. Wysocki 2009-02-14 14:31:29 UTC
References : http://lkml.org/lkml/2009/2/8/203
Comment 6 Rafael J. Wysocki 2009-02-15 06:29:53 UTC
Patch : http://lkml.org/lkml/2009/2/15/28
Comment 7 Mikko Vinni 2009-02-19 01:52:02 UTC
The patch posted by Etienne in http://lkml.org/lkml/2009/2/15/28 fixes a similar problem with hibernation on my HP nx9005 laptop with ATI Technologies Inc Radeon Mobility U1 (IGP 320M or something) graphics card.
I can't test suspend to ram on this machine due to another problem (http://bugzilla.kernel.org/show_bug.cgi?id=5884).

I can make the computer hang with the following steps without the patch (in 2.6.29-rc5-122-g... something):

1) log in to fail safe session (no 3d fancies)
2) check glxgears  (works)
3) echo test > /sys/power/disk
4) echo disk > /sys/power/state (resumes itself after 5 seconds, as expected)
5) try glxgears (immediate hang (mouse doesn't move, caps lock light doesn't change); fan gets on, so it is trying to do something; power button turns the machine off normally, etc.)

With Etienne's patch the computer doesn't hang anymore with the steps described above and even suspend to disk and resume with KDE 4 running works.

Not bad from a "shot in the dark" patch :)

Note You need to log in before you can comment on or make changes to this bug.