Bug 12608 - 2.6.29-rc powerpc G5 Xorg legacy_mem regression
2.6.29-rc powerpc G5 Xorg legacy_mem regression
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: PCI
All Linux
: P1 normal
Assigned To: drivers_pci@kernel-bugs.osdl.org
:
Depends on:
Blocks: 12398
  Show dependency treegraph
 
Reported: 2009-02-01 15:27 UTC by Rafael J. Wysocki
Modified: 2009-02-14 14:28 UTC (History)
0 users

See Also:
Kernel Version: 2.6.29-rc
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-02-01 15:27:13 UTC
Subject    : 2.6.29-rc powerpc G5 Xorg legacy_mem regression
Submitter  : Hugh Dickins <hugh@veritas.com>
Date       : 2009-01-21 21:12
References : http://marc.info/?l=linux-kernel&m=123257250431870&w=4
Handled-By : Benjamin Herrenschmidt <benh@kernel.crashing.org>

This entry is being used for tracking a regression from 2.6.28.  Please don't
close it until the problem is fixed in the mainline.

Caused by:

commit d3a54014e2a94bd37b7dee5e76e03f7bc4fab49a
Author: Benjamin Herrenschmidt <benh@kernel.crashing.org>
Date:   Wed Nov 12 14:38:53 2008 +1100

    PCI: Add legacy_io/mem to all busses

    Signed-off-by: Benjamin Herrenschmidt <benh@kernel.crashing.org>
    Signed-off-by: Jesse Barnes <jbarnes@virtuousgeek.org>

First-Bad-Commit : d3a54014e2a94bd37b7dee5e76e03f7bc4fab49a
Comment 1 Rafael J. Wysocki 2009-02-04 17:18:33 UTC
On Thursday 05 February 2009, Benjamin Herrenschmidt wrote:
> On Wed, 2009-02-04 at 11:24 +0100, Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> > 
> > The following bug entry is on the current list of known regressions
> > from 2.6.28.  Please verify if it still should be listed and let me know
> > (either way).
> 
> I still don't know what's the best way to handle that one... the bug is
> in X and I don't see a way to work around it without removing support
> for legacy memory access from the kernel :-( Or doing it in a way that
> doesn't allow userspace to differenciate between the kernel not
> supporting it vs. the HW not supporting it, causing X to fallback to
> even more broken crap.
> 
> I'll try to find out the extent of the X problem and whether that's
> fixable in a way that can hit distros.


Note You need to log in before you can comment on or make changes to this bug.