Bug 12606 - fb_mmap: circular locking dependency on hibernation
fb_mmap: circular locking dependency on hibernation
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Video(Other)
All Linux
: P1 normal
Assigned To: drivers_video-other
:
Depends on:
Blocks: 7216 12398
  Show dependency treegraph
 
Reported: 2009-02-01 14:59 UTC by Rafael J. Wysocki
Modified: 2009-02-08 14:05 UTC (History)
0 users

See Also:
Kernel Version: 2.6.29-rc2
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-02-01 14:59:43 UTC
Subject    : [2.6.29-rc2] fb_mmap: circular locking dependency on hibernation
Submitter  : Andrey Borzenkov <arvidjaar@mail.ru>
Date       : 2009-01-27 18:37
References : http://marc.info/?l=linux-kernel&m=123308162731408&w=4

This entry is being used for tracking a regression from 2.6.28.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2009-02-04 17:43:05 UTC
Handled-By : Andrea Righi <righi.andrea@gmail.com>
Patch : http://marc.info/?l=linux-kernel&m=123365581406194&w=2
Comment 2 Rafael J. Wysocki 2009-02-08 14:04:26 UTC
On Sunday 08 February 2009, Andrea Righi wrote:
> On 2009-02-08 20:21, Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> > 
> > The following bug entry is on the current list of known regressions
> > from 2.6.28.  Please verify if it still should be listed and let me know
> > (either way).
> > 
> > 
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=12606
> > Subject		: fb_mmap: circular locking dependency on hibernation
> > Submitter	: Andrey Borzenkov <arvidjaar@mail.ru>
> > Date		: 2009-01-27 18:37 (13 days old)
> > References	: http://marc.info/?l=linux-kernel&m=123308162731408&w=4
> > Handled-By	: Andrea Righi <righi.andrea@gmail.com>
> > Patch		: http://marc.info/?l=linux-kernel&m=123365581406194&w=2
> 
> This is fixed by:
> 
> commit 1f5e31d7e55ac7fbd4ec5e5b20c8868b0e4564c9
> Author: Andrea Righi <righi.andrea@gmail.com>
> Date:   Wed Feb 4 15:12:03 2009 -0800
> 
>     fbmem: don't call copy_from/to_user() with mutex held


Note You need to log in before you can comment on or make changes to this bug.