Bug 12602 - CRED changes causing setuid failures
CRED changes causing setuid failures
Status: CLOSED CODE_FIX
Product: Other
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: other_other
:
Depends on:
Blocks: 12398
  Show dependency treegraph
 
Reported: 2009-02-01 14:27 UTC by Rafael J. Wysocki
Modified: 2009-02-08 11:40 UTC (History)
0 users

See Also:
Kernel Version: 2.6.29-rc2
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-02-01 14:27:24 UTC
Subject    : [2.6.29-rc2 regression] CRED changes causing setuid failures
Submitter  : David Smith <dsmith@redhat.com>
Date       : 2009-01-29 21:35
References : http://marc.info/?l=linux-kernel&m=123326501813668&w=4

This entry is being used for tracking a regression from 2.6.28.  Please don't
close it until the problem is fixed in the mainline.

Reportedly caused by:

commit d84f4f992cbd76e8f39c488cf0c5d123843923b1
Author: David Howells <dhowells@redhat.com>
Date:   Fri Nov 14 10:39:23 2008 +1100

    CRED: Inaugurate COW credentials

    Signed-off-by: David Howells <dhowells@redhat.com>
    Acked-by: James Morris <jmorris@namei.org>
    Signed-off-by: James Morris <jmorris@namei.org>

First-Bad-Commit : d84f4f992cbd76e8f39c488cf0c5d123843923b1
Comment 1 Rafael J. Wysocki 2009-02-04 15:46:46 UTC
On Wednesday 04 February 2009, David Smith wrote:
> Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> > 
> > The following bug entry is on the current list of known regressions
> > from 2.6.28.  Please verify if it still should be listed and let me know
> > (either way).
> > 
> > 
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=12602
> > Subject		: CRED changes causing setuid failures
> > Submitter	: David Smith <dsmith@redhat.com>
> > Date		: 2009-01-29 21:35 (7 days old)
> > First-Bad-Commit: http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=d84f4f992cbd76e8f39c488cf0c5d123843923b1
> > References	: http://marc.info/?l=linux-kernel&m=123326501813668&w=4
> 
> I've verified this still exists in 2.6.29-rc3.
> 
> (git describe says I'm at v2.6.29-rc3-495-gdcf6a79)

Comment 2 Rafael J. Wysocki 2009-02-08 11:40:09 UTC
Fixed by commit 0bf2f3aec5474da80a60e1baca629af87ecb67b6 .

Note You need to log in before you can comment on or make changes to this bug.