Bug 12587 - using >= linux-2.6.26-gentoo-r4 machine hangs when start hibernating
using >= linux-2.6.26-gentoo-r4 machine hangs when start hibernating
Status: CLOSED DUPLICATE of bug 12584
Product: Power Management
Classification: Unclassified
Component: Hibernation/Suspend
All Linux
: P1 normal
Assigned To: power-management_other
:
Depends on:
Blocks: 7216
  Show dependency treegraph
 
Reported: 2009-01-31 09:13 UTC by Karlis.Repsons
Modified: 2009-04-02 05:01 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.26
Tree: Mainline
Regression: Yes


Attachments

Description Karlis.Repsons 2009-01-31 09:13:59 UTC
Latest working kernel version:2.6.25-gentoo-r7
Earliest failing kernel version:linux-2.6.26-gentoo-r4
Distribution:gentoo
Hardware Environment:x86-64
Software Environment:running gentoo, no Xorg in test
Problem Description: 

so I try doing this:
echo 17179869184 > /sys/power/image_size
echo disk > /sys/power/state

and it results in hang with 2.6.26. Console gets completely blank, no disk access and for more than minute like that, so I have to hard-reset the system. Also can't access with ssh during that hang.

Steps to reproduce:
get Asus P5Q-E with core2 duo, install gentoo, compile kernels mentioned above and for newer one take config of .25, make mrproper && cp /path/to/config.25 .config && make menuconfig && make -j3 && make modules_install 
I changed nothing in menuconfig. and do echo ...

Comments:
Can attach .config or send by mail, but there is little of helpful in it, I think. No nvidia was compiled for testing kernels, so no binary drivers were loaded.
Comment 1 Rafael J. Wysocki 2009-01-31 10:04:20 UTC
Please try 2.6.29-rc4 when it's out and let me know whether it works.  If possible, please test kernels from kernel.org rather than distro kernels.
Comment 2 Zhang Rui 2009-03-18 19:58:41 UTC

*** This bug has been marked as a duplicate of bug 12584 ***

Note You need to log in before you can comment on or make changes to this bug.