Bug 12584 - using >= linux-2.6.26-gentoo-r4 machine hangs when start hibernating
using >= linux-2.6.26-gentoo-r4 machine hangs when start hibernating
Status: CLOSED CODE_FIX
Product: Power Management
Classification: Unclassified
Component: Hibernation/Suspend
All Linux
: P1 normal
Assigned To: Rafael J. Wysocki
:
: 12587 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-31 04:39 UTC by Karlis.Repsons
Modified: 2011-07-30 05:52 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.26
Tree: Mainline
Regression: Yes


Attachments

Description Karlis.Repsons 2009-01-31 04:39:31 UTC
Latest working kernel version:2.6.25-gentoo-r7
Earliest failing kernel version:linux-2.6.26-gentoo-r4
Distribution:gentoo
Hardware Environment:x86-64
Software Environment:running gentoo, no Xorg in test
Problem Description: 

so I try doing this:
echo 17179869184 > /sys/power/image_size
echo disk > /sys/power/state

and it results in hang with 2.6.26. Console gets completely blank, no disk access and for more than minute like that, so I have to hard-reset the system. Also can't access with ssh during that hang.

Steps to reproduce:
get Asus P5Q-E with core2 duo, install gentoo, compile kernels mentioned above and for newer one take config of .25, make mrproper && cp /path/to/config.25 .config && make menuconfig && make -j3 && make modules_install 
I changed nothing in menuconfig. and do echo ...

Comments:
Can attach .config or send by mail, but there is little of helpful in it, I think. No nvidia was compiled for testing kernels, so no binary drivers were loaded.
Comment 1 Andrew Morton 2009-02-02 20:30:43 UTC
Rafael, could you please have a think about this one and
route it appropriately if that should be done?

Thanks.
Comment 2 Rafael J. Wysocki 2009-02-03 00:12:45 UTC
Karlis, please try to boot the kernel with acpi_sleep=old_ordering in the command line and see if that helps.
Comment 3 Karlis.Repsons 2009-02-03 01:49:05 UTC
I tried it, but no success. It still hangs on 2.6.26-r4.
Comment 4 Rafael J. Wysocki 2009-02-03 08:25:52 UTC
Please try a newer kernel.  Preferably the current mainline.
Comment 5 Zhang Rui 2009-03-18 19:57:22 UTC
ping Karlis, does the problem still exist in the current mainline kernel?
Comment 6 Zhang Rui 2009-03-18 19:58:41 UTC
*** Bug 12587 has been marked as a duplicate of this bug. ***
Comment 7 Karlis.Repsons 2009-03-20 02:04:08 UTC
Zhang,
You mean 2.6.28.8 kernel? I ask because somehow I remember, I was told about trying 2.6.29... I can live with 2.6.25 and so I've done.
Well, I can try, but a little later. It takes some work.
Comment 8 Karlis.Repsons 2009-03-23 04:42:46 UTC
I am back. Built 2.6.28.8 and it works well. However, I threw away some deprecated modules / parts of kernel in my new config, but, as they were all deprecated, I consider there is no real need to worry.
Comment 9 Zhang Rui 2009-06-23 08:07:40 UTC
this seems to be a problem that has already been fixed in the upsteam kernel.
please reopen it if the problem still exists in a later kernel release, say 2.6.30.

Note You need to log in before you can comment on or make changes to this bug.