Bug 12575 - BUG about mutex locking inbalance in dmesg when using intel modeset
BUG about mutex locking inbalance in dmesg when using intel modeset
Status: RESOLVED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel)
All Linux
: P1 normal
Assigned To: drivers_video-dri
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-29 12:27 UTC by Daniel Vetter
Modified: 2009-01-30 13:51 UTC (History)
0 users

See Also:
Kernel Version: 2.6.29-rc2-00442-g152a649
Tree: Mainline
Regression: ---


Attachments
complete dmesg (40.18 KB, text/x-log)
2009-01-29 12:29 UTC, Daniel Vetter
Details

Description Daniel Vetter 2009-01-29 12:27:07 UTC
Distribution: Debian unstable amd 64
Hardware Environment: IBM Thinkpad X40 (lspic output below)
Software Environment: xorg 1.6 rc1 and intel 2.6.1 from debian experimental
Problem Description: When loading the intel drm with modesetting on (X killed)

# rmmod i915 && modprobe i915 modeset=1

the following BUG report gets dumped to dmesg (before firing up X):

=====================================
[ BUG: bad unlock balance detected! ]
-------------------------------------
modprobe/4547 is trying to release lock (&dev->mode_config.mutex) at:
[<c02e02d4>] mutex_unlock+0xd/0xf
but there are no more locks to release!

other info that might help us debug this:
no locks held by modprobe/4547.

stack backtrace:
Pid: 4547, comm: modprobe Not tainted 2.6.29-rc2-00442-g152a649 #24
Call Trace:
 [<c02df682>] ? printk+0x14/0x1a
 [<c013ebb0>] print_unlock_inbalance_bug+0xcc/0xd7
 [<c02d0020>] ? xfrm_alloc_spi+0x10b/0x19e
 [<c0128a41>] ? process_timeout+0x0/0xf
 [<c02df682>] ? printk+0x14/0x1a
 [<c02e02d4>] ? mutex_unlock+0xd/0xf
 [<c013ee53>] lock_release+0x90/0x151
 [<c02e0271>] __mutex_unlock_slowpath+0x9f/0xf5
 [<c02e02d4>] mutex_unlock+0xd/0xf
 [<f8d1f9bb>] intel_lvds_get_modes+0x67/0x92 [i915]
 [<f8c7639c>] drm_helper_probe_single_connector_modes+0xb8/0x194 [drm]
 [<f8c764af>] drm_helper_probe_connector_modes+0x37/0x62 [drm]
 [<f8c764fc>] drm_helper_initial_config+0x22/0x154 [drm]
 [<f8d14ff4>] i915_driver_load+0x720/0x767 [i915]
 [<f8c6fc39>] drm_get_dev+0x2ee/0x383 [drm]
 [<f8c6b816>] drm_init+0x6b/0xa0 [drm]
 [<f8848000>] ? i915_init+0x0/0x48 [i915]
 [<f8848046>] i915_init+0x46/0x48 [i915]
 [<c0101151>] _stext+0x69/0x16d
 [<c02e02d4>] ? mutex_unlock+0xd/0xf
 [<c01c22f2>] ? sysfs_addrm_finish+0x1c/0x1d2
 [<c013cf9d>] ? lock_release_holdtime+0x1a/0x178
 [<c02e02d4>] ? mutex_unlock+0xd/0xf
 [<c02e02d4>] ? mutex_unlock+0xd/0xf
 [<c013d98f>] ? __lock_acquire+0x498/0x82f
 [<c013d98f>] ? __lock_acquire+0x498/0x82f
 [<c013e41f>] ? debug_check_no_locks_freed+0xeb/0xfe
 [<c013d98f>] ? __lock_acquire+0x498/0x82f
 [<c015a702>] ? tracepoint_update_probe_range+0x1f/0x8d
 [<c013cf9d>] ? lock_release_holdtime+0x1a/0x178
 [<c02e02d4>] ? mutex_unlock+0xd/0xf
 [<c013cf9d>] ? lock_release_holdtime+0x1a/0x178
 [<c01354b9>] ? __blocking_notifier_call_chain+0x45/0x51
 [<c0134c5d>] ? up_read+0x1b/0x2e
 [<c01354b9>] ? __blocking_notifier_call_chain+0x45/0x51
 [<c0145db1>] sys_init_module+0x8e/0x191
 [<c0102e91>] sysenter_do_call+0x12/0x31

lspci -nn output on this box:

00:00.0 Host bridge [0600]: Intel Corporation 82852/82855 GM/GME/PM/GMV Processor to I/O Controller [8086:3580] (rev 02)
00:00.1 System peripheral [0880]: Intel Corporation 82852/82855 GM/GME/PM/GMV Processor to I/O Controller [8086:3584] (rev 02)
00:00.3 System peripheral [0880]: Intel Corporation 82852/82855 GM/GME/PM/GMV Processor to I/O Controller [8086:3585] (rev 02)
00:02.0 VGA compatible controller [0300]: Intel Corporation 82852/855GM Integrated Graphics Device [8086:3582] (rev 02)
00:02.1 Display controller [0380]: Intel Corporation 82852/855GM Integrated Graphics Device [8086:3582] (rev 02)
00:1d.0 USB Controller [0c03]: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1 [8086:24c2] (rev 01)
00:1d.1 USB Controller [0c03]: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #2 [8086:24c4] (rev 01)
00:1d.2 USB Controller [0c03]: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #3 [8086:24c7] (rev 01)
00:1d.7 USB Controller [0c03]: Intel Corporation 82801DB/DBM (ICH4/ICH4-M) USB2 EHCI Controller [8086:24cd] (rev 01)
00:1e.0 PCI bridge [0604]: Intel Corporation 82801 Mobile PCI Bridge [8086:2448] (rev 81)
00:1f.0 ISA bridge [0601]: Intel Corporation 82801DBM (ICH4-M) LPC Interface Bridge [8086:24cc] (rev 01)
00:1f.1 IDE interface [0101]: Intel Corporation 82801DBM (ICH4-M) IDE Controller [8086:24ca] (rev 01)
00:1f.3 SMBus [0c05]: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) SMBus Controller [8086:24c3] (rev 01)
00:1f.5 Multimedia audio controller [0401]: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller [8086:24c5] (rev 01)
00:1f.6 Modem [0703]: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Modem Controller [8086:24c6] (rev 01)
02:00.0 CardBus bridge [0607]: Ricoh Co Ltd RL5c476 II [1180:0476] (rev 8d)
02:00.1 SD Host controller [0805]: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter [1180:0822] (rev 13)
02:01.0 Ethernet controller [0200]: Intel Corporation 82541GI Gigabit Ethernet Controller [8086:1077]
02:02.0 Ethernet controller [0200]: Atheros Communications Inc. AR5212 802.11abg NIC [168c:1014] (rev 01)

I'll paste the complete dmesg (including some other stuffed caused by X starting) shortly
Comment 1 Daniel Vetter 2009-01-29 12:29:04 UTC
Created attachment 20042 [details]
complete dmesg

Correction: Of course, it's a 32 bit box, not amd64 (I mixed that one up, sorry).
Comment 2 Andrew Morton 2009-01-29 12:50:40 UTC
thanks, I merged a fix
Comment 3 guilherme malschitzky schroeder 2009-01-30 13:47:59 UTC
Andrew,

I have a problem with intelfb and X too.
I'm using ubuntu jaunty (x.org 1.6rc1 and intel 2.6.1).
When i enable CONFIG_DRM_I915_KMS=y it just boot fine but when i start kdm (or even startx) i just got a blank screen.
A known solutation is to disable CONFIG_DRM_I915_KMS=y and removing any vga=xxx from grub. It's boots without framebuffer and them X/KDM starts fine.
Comment 4 guilherme malschitzky schroeder 2009-01-30 13:51:22 UTC
sorry, i didn't give much details:

00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)

It's a GM45 board.

(II) intel(0): Integrated Graphics Chipset: Intel(R) Mobile Intel® GM45 Express Chipset

%s/solutation/solution/g

Linux version 2.6.29-rc3 (alemao@dub) (gcc version 4.3.3 (Ubuntu 4.3.3-3ubuntu1) ) #11 SMP Fri Jan 30 19:34:29 BRST 2009

Note You need to log in before you can comment on or make changes to this bug.