Bug 12573 - ieee1394/video1394: kernel BUG at drivers/ieee1394/dma.c:173
Summary: ieee1394/video1394: kernel BUG at drivers/ieee1394/dma.c:173
Status: CLOSED WILL_NOT_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: IEEE1394 (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: drivers_ieee1394
URL:
Keywords:
Depends on:
Blocks: 10046
  Show dependency tree
 
Reported: 2009-01-29 10:41 UTC by Stefan Richter
Modified: 2009-12-25 11:19 UTC (History)
0 users

See Also:
Kernel Version: 2.6.25, 2.6.27, 2.6.28
Tree: Mainline
Regression: No


Attachments

Description Stefan Richter 2009-01-29 10:41:28 UTC
Using the video1394 driver with certain parameters crashes the kernel.
http://marc.info/?l=linux1394-devel&t=123305327200009

Judging from the history of the involved code, it is likely that this problem exists in much older kernels too.

Meanwhile, firewire-core together with the respective libdc1394 backend has become available as an actively maintained alternative to video1394.  Hence I'm linking this to bug 10046 but am not closing it right away due to the severity of the issue.

Note You need to log in before you can comment on or make changes to this bug.