Bug 12541 - I/O resource conflict between ACPI and i2c_i801 module
Summary: I/O resource conflict between ACPI and i2c_i801 module
Status: CLOSED DUPLICATE of bug 12376
Alias: None
Product: ACPI
Classification: Unclassified
Component: Other (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: acpi_other
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-01-26 02:29 UTC by Atanas Zhelev
Modified: 2009-03-09 19:02 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.28.1
Tree: Mainline
Regression: ---


Attachments
lspci -vv output (16.01 KB, text/plain)
2009-01-26 02:30 UTC, Atanas Zhelev
Details
full dmesg output (35.68 KB, text/plain)
2009-01-26 02:33 UTC, Atanas Zhelev
Details
acpidump from this laptop (141.52 KB, text/plain)
2009-01-26 02:35 UTC, Atanas Zhelev
Details
dmidecode output (14.38 KB, text/plain)
2009-01-26 02:36 UTC, Atanas Zhelev
Details

Description Atanas Zhelev 2009-01-26 02:29:21 UTC
Latest working kernel version: unknown
Earliest failing kernel version: 2.6.28
Distribution: ArchLinux x86_64, self compiled kernel from ftp.kernel.org
Hardware Environment: dell stdio 1537


Problem Description:
dmesg reports I/O resource conflict
i801_smbus 0000:00:1f.3: PCI INT C -> GSI 19 (level, low) -> IRQ 19                                              
ACPI: I/O resource 0000:00:1f.3 [0x1c00-0x1c1f] conflicts with ACPI region SMBI [0x1c00-0x1c0f]                  
ACPI: Device needs an ACPI driver

blacklisting the i2c_i801 module gets rid of the message

There is a similar bug report but the eror message is a bit different
http://bugzilla.kernel.org/show_bug.cgi?id=12376

and another one, exactly the same, in red hat bugzilla
https://bugzilla.redhat.com/show_bug.cgi?id=470479


Steps to reproduce:
boot, check dmesg
Comment 1 Atanas Zhelev 2009-01-26 02:30:55 UTC
Created attachment 19992 [details]
lspci -vv output
Comment 2 Atanas Zhelev 2009-01-26 02:33:01 UTC
Created attachment 19993 [details]
full dmesg output
Comment 3 Atanas Zhelev 2009-01-26 02:35:11 UTC
Created attachment 19994 [details]
acpidump from this laptop
Comment 4 Atanas Zhelev 2009-01-26 02:36:43 UTC
Created attachment 19995 [details]
dmidecode output
Comment 5 Zhang Rui 2009-02-25 16:57:32 UTC

*** This bug has been marked as a duplicate of bug 12376 ***

Note You need to log in before you can comment on or make changes to this bug.