Bug 12529 - usb hhd doesn't work
Summary: usb hhd doesn't work
Status: RESOLVED INVALID
Alias: None
Product: Drivers
Classification: Unclassified
Component: USB (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Greg Kroah-Hartman
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-01-23 14:07 UTC by Lionel SANCHEZ
Modified: 2012-02-22 21:00 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.27
Tree: Mainline
Regression: Yes


Attachments
dmesg of first plug of my usb-hdd (2.25 KB, application/octet-stream)
2009-01-23 14:15 UTC, Lionel SANCHEZ
Details
dmesg extract of next usb-hdd plugs (3.98 KB, application/octet-stream)
2009-01-23 14:16 UTC, Lionel SANCHEZ
Details
usbmon activity of usb bus on first usb-hdd plug (101.41 KB, application/octet-stream)
2009-01-23 14:17 UTC, Lionel SANCHEZ
Details
Here are queried informations (345.50 KB, application/x-tar)
2009-01-27 02:31 UTC, Lionel SANCHEZ
Details
2.6.26.7 "/proc/bus/usb/devices" & "lsusb -v" (50.00 KB, application/octet-stream)
2009-01-27 14:59 UTC, Lionel SANCHEZ
Details

Description Lionel SANCHEZ 2009-01-23 14:07:11 UTC
Latest working kernel version:2.6.26.*
Earliest failing kernel version:2.6.27.*
Distribution: Gentoo
Hardware Environment: amd64 on nforce4
Software Environment: vanilla-2.6.28.1+hal-0.5.11+dbus-1.2.3+udev-135+KDE (but not related to this DM : same pb with others DM/WM)
Problem Description:
When plugging my usb-hdd it first seems to be found correctly : dmesg found the device and start to create a /dev/sd?? entry but after message "device scan complete" it fails and dmesg starts growing with lots of 
    sd 6:0:0:0: [sdd] Sense Key : 0x0 [current]
    sd 6:0:0:0: [sdd] ASC=0x0 ASCQ=0x0
and the activity disk led start blinking. The device entry disappear (but well I didn't really see it).

Steps to reproduce:
Just use an earlier kernel (from 2.6.27) and plug the usb-hdd.
Notice that I make some different tests : everything equal (same udev/dbus/hal and hardware) but vanilla-2.6.26.* it works perfectly.
No matter what kernel version is loaded my usb stick works perfectly too.
Comment 1 Lionel SANCHEZ 2009-01-23 14:15:49 UTC
Created attachment 19970 [details]
dmesg of first plug of my usb-hdd
Comment 2 Lionel SANCHEZ 2009-01-23 14:16:22 UTC
Created attachment 19971 [details]
dmesg extract of next usb-hdd plugs
Comment 3 Lionel SANCHEZ 2009-01-23 14:17:39 UTC
Created attachment 19972 [details]
usbmon activity of usb bus on first usb-hdd plug

I don't know how to read this stuff !!! :-/
Comment 4 Anonymous Emailer 2009-01-23 21:08:17 UTC
Reply-To: akpm@linux-foundation.org


(switched to email.  Please respond via emailed reply-to-all, not via the
bugzilla web interface).

On Fri, 23 Jan 2009 14:07:11 -0800 (PST) bugme-daemon@bugzilla.kernel.org wrote:

> http://bugzilla.kernel.org/show_bug.cgi?id=12529
> 
>            Summary: usb hhd doesn't work
>            Product: Drivers
>            Version: 2.5
>      KernelVersion: till 2.6.27
>           Platform: All
>         OS/Version: Linux
>               Tree: Mainline
>             Status: NEW
>           Severity: normal
>           Priority: P1
>          Component: USB
>         AssignedTo: greg@kroah.com
>         ReportedBy: lionel.sanchez@gmail.com
> 
> 
> Latest working kernel version:2.6.26.*
> Earliest failing kernel version:2.6.27.*

A regression.

> Distribution: Gentoo
> Hardware Environment: amd64 on nforce4
> Software Environment: vanilla-2.6.28.1+hal-0.5.11+dbus-1.2.3+udev-135+KDE
> (but
> not related to this DM : same pb with others DM/WM)
> Problem Description:
> When plugging my usb-hdd it first seems to be found correctly : dmesg found
> the
> device and start to create a /dev/sd?? entry but after message "device scan
> complete" it fails and dmesg starts growing with lots of 
>     sd 6:0:0:0: [sdd] Sense Key : 0x0 [current]
>     sd 6:0:0:0: [sdd] ASC=0x0 ASCQ=0x0
> and the activity disk led start blinking. The device entry disappear (but
> well
> I didn't really see it).
> 
> Steps to reproduce:
> Just use an earlier kernel (from 2.6.27) and plug the usb-hdd.
> Notice that I make some different tests : everything equal (same
> udev/dbus/hal
> and hardware) but vanilla-2.6.26.* it works perfectly.
> No matter what kernel version is loaded my usb stick works perfectly too.
> 
Comment 5 Alan Stern 2009-01-24 09:51:11 UTC
On Fri, 23 Jan 2009, Andrew Morton wrote:

> > http://bugzilla.kernel.org/show_bug.cgi?id=12529
> > 
> >            Summary: usb hhd doesn't work

> > When plugging my usb-hdd it first seems to be found correctly : dmesg found
> the
> > device and start to create a /dev/sd?? entry but after message "device scan
> > complete" it fails and dmesg starts growing with lots of 
> >     sd 6:0:0:0: [sdd] Sense Key : 0x0 [current]
> >     sd 6:0:0:0: [sdd] ASC=0x0 ASCQ=0x0
> > and the activity disk led start blinking. The device entry disappear (but
> well
> > I didn't really see it).

Collecting a usbmon log was a good idea, but you used the wrong bus!  
The device was attached to bus 1 and you monitored bus 2.  Can you 
collect another usbmon log, this time for bus 1?

You didn't say which kernel version your logs were for.  Can you try 
running 2.6.29-rc2?

Also, can you attach either the entry in /proc/bus/usb/devices 
or else the "lsusb -v" output for your drive (you may have to run 
2.6.26 to get this information).

Alan Stern
Comment 6 Lionel SANCHEZ 2009-01-26 01:23:20 UTC
Erf ! My choice of bus number was based on kernel documentation by plugging an usb key on same port ... But I probably make a mistake with this. T_T

All logs come from an 2.6.28.1 vanilla kernel.

I'll make a new usbmon this evening and give you all informations you ask for.

Thanks for helping !

Lionel
Comment 7 Lionel SANCHEZ 2009-01-27 02:31:40 UTC
Created attachment 20006 [details]
Here are queried informations

Usbmon from first usb bus of 2.6.28.1 & 2.6.29_RC2 kernels.
Also "lsusb -v" & "cat /proc/bus/devices" of these two kernels.

Testing on 2.6.29-RC2 seems to solve the problem (I can mount my hdd-usb hard drive). But I saw some ugly things on dmesg so I put it in the tar file given here.

Ooops ... I just realise that the "lsusb -v" have to come from a working kernel ! Hope that 2.6.29_RC2 will make the stuff. If not, I'll give you asap the good information.

Thanks.
Comment 8 Lionel SANCHEZ 2009-01-27 14:59:32 UTC
Created attachment 20019 [details]
2.6.26.7 "/proc/bus/usb/devices" & "lsusb -v" 

In doubt, here are 2.6.26 queried informations
Comment 9 Lionel SANCHEZ 2009-02-06 06:21:00 UTC
Hello,

Without news I try latest 2.6.28.3 and I can mount my usb-hdd drive.
Dmesg is always complaining with lots of
"d 10:0:0:0: [sdd] Result: hostbyte=0x00 driverbyte=0x08
sd 10:0:0:0: [sdd] Sense Key : 0x3 [current]
sd 10:0:0:0: [sdd] ASC=0x14 ASCQ=0x0
end_request: I/O error, dev sdd, sector 117304992"
but I can access to my drive.

Dunno how to change this bug (solved or anything) so I'll let you do that.

Thanks.
Comment 10 Alan Stern 2009-03-12 08:16:32 UTC
There's a fix which will appear in 2.6.31 (I hope!) and which should get rid of those remaining error messages.  There's only seven of them, so it's not too bad.

In the meantime, if you're happy about the current situation then Greg KH can close out this bug report.
Comment 11 Lionel SANCHEZ 2009-03-12 09:00:04 UTC
O_o : You know three releases before what fix will be included in kernel sources !
I'm impressed about that (just thinking work is done only on current and RC sources).

About this bug, I'm not really happy about the current situation but my usb-hdd is working. And that's what I *really* want first. ;-)

Let you (or Greg KH) close this bug or put it in "will_fix_later" state.
Comment 12 Greg Kroah-Hartman 2012-02-22 21:00:07 UTC
All USB bugs should be sent to the linux-usb@vger.kernel.org mailing 
list, and not entered into bugzilla.  Please bring this issue up there,
if it is still a problem in the latest kernel release.

Note You need to log in before you can comment on or make changes to this bug.