Bug 12508 - "powerpc/pci: Reserve legacy regions on PCI" broke my G3
"powerpc/pci: Reserve legacy regions on PCI" broke my G3
Status: CLOSED CODE_FIX
Product: Platform Specific/Hardware
Classification: Unclassified
Component: PPC-32
All Linux
: P1 normal
Assigned To: platform_ppc-32
:
Depends on:
Blocks: 12398
  Show dependency treegraph
 
Reported: 2009-01-19 15:10 UTC by Rafael J. Wysocki
Modified: 2009-02-08 16:38 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.28-git12
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-01-19 15:10:47 UTC
Subject    : [BUG] 2.6.28-git12: "powerpc/pci: Reserve legacy regions on PCI" broke my G3
Submitter  : Mikael Pettersson <mikpe@it.uu.se>
Date       : 2009-01-17 22:46
References : http://marc.info/?l=linux-kernel&m=123223247325452&w=4
Handled-By : Benjamin Herrenschmidt <benh@kernel.crashing.org>

This entry is being used for tracking a regression from 2.6.28.  Please don't
close it until the problem is fixed in the mainline.

Caused by:

commit c1f343028d35ba4e88cd4a3c44e0d8b8a84264ee
Author: Benjamin Herrenschmidt <benh@kernel.crashing.org>
Date:   Tue Nov 11 17:45:52 2008 +0000

    powerpc/pci: Reserve legacy regions on PCI

    Signed-off-by: Benjamin Herrenschmidt <benh@kernel.crashing.org>

First-Bad-Commit : c1f343028d35ba4e88cd4a3c44e0d8b8a84264ee
Comment 1 Rafael J. Wysocki 2009-02-08 16:38:10 UTC
Fixed by commit 59b608c2c33feacc8be281ec3ba9ca2a3a5cb9a7 .

Note You need to log in before you can comment on or make changes to this bug.