Bug 12505 - 2.6.29-rc1 Firefox crashing on page load
2.6.29-rc1 Firefox crashing on page load
Status: CLOSED CODE_FIX
Product: Other
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: other_other
:
Depends on:
Blocks: 12398
  Show dependency treegraph
 
Reported: 2009-01-19 14:55 UTC by Rafael J. Wysocki
Modified: 2009-02-04 17:07 UTC (History)
0 users

See Also:
Kernel Version: 2.6.29-rc1
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-01-19 14:55:09 UTC
Subject    : 2.6.29-rc1 Firefox crashing on page load
Submitter  : Justin Madru <jdm64@gawab.com>
Date       : 2009-01-16 20:56
References : http://marc.info/?l=linux-kernel&m=123213941914274&w=4
Handled-By : "Justin P. Mattock" <justinmattock@gmail.com>

This entry is being used for tracking a regression from 2.6.28.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2009-02-03 15:08:56 UTC
Caused by:

commit 4217458dafaa57d8e26a46f5d05ab8c53cf64191
Author: Hiroshi Shimamoto <h-shimamoto@ct.jp.nec.com>
Date:   Fri Dec 5 17:17:09 2008 -0800

   x86: signal: change type of paramter for sys_rt_sigreturn()

   Signed-off-by: Hiroshi Shimamoto <h-shimamoto@ct.jp.nec.com>
   Signed-off-by: Ingo Molnar <mingo@elte.hu>

First-Bad-Commit : 4217458dafaa57d8e26a46f5d05ab8c53cf64191
Comment 2 Rafael J. Wysocki 2009-02-04 17:07:14 UTC
On Wednesday 04 February 2009, Justin Mattock wrote:
> On Wed, Feb 4, 2009 at 4:46 PM, Ingo Molnar <mingo@elte.hu> wrote:
> >
> > * Justin Mattock <justinmattock@gmail.com> wrote:
> >
> >> On Wed, Feb 4, 2009 at 2:24 AM, Rafael J. Wysocki <rjw@sisk.pl> wrote:
> >> > This message has been generated automatically as a part of a report
> >> > of recent regressions.
> >> >
> >> > The following bug entry is on the current list of known regressions
> >> > from 2.6.28.  Please verify if it still should be listed and let me know
> >> > (either way).
> >> >
> >> >
> >> > Bug-Entry       : http://bugzilla.kernel.org/show_bug.cgi?id=12505
> >> > Subject         : 2.6.29-rc1 Firefox crashing on page load
> >> > Submitter       : Justin Madru <jdm64@gawab.com>
> >> > Date            : 2009-01-16 20:56 (20 days old)
> >> > First-Bad-Commit: http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=4217458dafaa57d8e26a46f5d05ab8c53cf64191
> >> > References      : http://marc.info/?l=linux-kernel&m=123213941914274&w=4
> >> > Handled-By      : Justin P. Mattock <justinmattock@gmail.com>
> >> >
> >> >
> >> >
> >>
> >> Well the hardest for this, was to reproduce
> >> the error.(never did). I guess it can be taken
> >> of if there was a patch for the fix, and the patch
> >> made it into the main tree. but if this  is a firefox
> >> issue, then a report needs to be filed with them.
> >> so overall my answer is "I don't know."
> >> :^)
> >
> > the error is spurious because gcc randomly stomps on user register state so
> > the effects can be rather random and unpredictable.
> >
> > The fix:
> >
> >  552b8aa: Revert "x86: signal: change type of paramter for sys_rt_sigreturn()"
> >
> > was included in -rc2 already, so please test latest -git whether you can see
> > any such troubles.


Note You need to log in before you can comment on or make changes to this bug.