Bug 12503 - [slab corruption] BUG key_jar: Poison overwritten
[slab corruption] BUG key_jar: Poison overwritten
Status: CLOSED UNREPRODUCIBLE
Product: Memory Management
Classification: Unclassified
Component: Slab Allocator
All Linux
: P1 normal
Assigned To: Andrew Morton
:
Depends on:
Blocks: 12398
  Show dependency treegraph
 
Reported: 2009-01-19 14:45 UTC by Rafael J. Wysocki
Modified: 2009-02-13 15:13 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.29-rc
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-01-19 14:45:33 UTC
Subject    : [slab corruption] BUG key_jar: Poison overwritten
Submitter  : Ingo Molnar <mingo@elte.hu>
Date       : 2009-01-15 18:16
References : http://marc.info/?l=linux-kernel&m=123204353425825&w=4
Handled-By : David Howells <dhowells@redhat.com>
Notify-Also : "Vegard Nossum" <vegard.nossum@gmail.com>

This entry is being used for tracking a regression from 2.6.28.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2009-02-08 16:36:19 UTC
On Sunday 08 February 2009, Ingo Molnar wrote:
> 
> * Rafael J. Wysocki <rjw@sisk.pl> wrote:
> 
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> > 
> > The following bug entry is on the current list of known regressions
> > from 2.6.28.  Please verify if it still should be listed and let me know
> > (either way).
> > 
> > 
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=12503
> > Subject		: [slab corruption] BUG key_jar: Poison overwritten
> > Submitter	: Ingo Molnar <mingo@elte.hu>
> > Date		: 2009-01-15 18:16 (25 days old)
> > References	: http://marc.info/?l=linux-kernel&m=123204353425825&w=4
> > Handled-By	: David Howells <dhowells@redhat.com>
> 
> This slab corruption has not triggered again. It's either a very rare thing (in 
> which case there's no realistic way to debug it via this angle), or it got fixed 
> meanwhile.
> 
> Please close it. Thanks,

Comment 2 Rafael J. Wysocki 2009-02-13 15:13:19 UTC
Patch : http://marc.info/?l=linux-kernel&m=123453394630727&w=4
Comment 3 Ingo Molnar 2009-02-14 02:14:02 UTC
> Patch : http://marc.info/?l=linux-kernel&m=123453394630727&w=4

Upstream fix:

  fb5ae64: User namespaces: Only put the userns when we unhash the uid

also in -rc5.

	Ingo


Note You need to log in before you can comment on or make changes to this bug.