Bug 12499 - Problem with using bluetooth adaper connected to usb port
Problem with using bluetooth adaper connected to usb port
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Bluetooth
All Linux
: P1 normal
Assigned To: drivers_bluetooth@kernel-bugs.osdl.org
:
Depends on:
Blocks: 12398
  Show dependency treegraph
 
Reported: 2009-01-19 14:21 UTC by Rafael J. Wysocki
Modified: 2009-05-17 10:21 UTC (History)
0 users

See Also:
Kernel Version: 2.6.29-rc1
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-01-19 14:21:14 UTC
Subject    : [2.6.29-rc1] Problem with using bluetooth adaper connected to usb port
Submitter  : "Maciej Rutecki" <maciej.rutecki@gmail.com>
Date       : 2009-01-13 18:34
References : http://marc.info/?l=linux-kernel&m=123187185426236&w=4

This entry is being used for tracking a regression from 2.6.28.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2009-04-07 21:12:26 UTC
On Tuesday 07 April 2009, Marcel Holtmann wrote:
>
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> > 
> > The following bug entry is on the current list of known regressions
> > from 2.6.28.  Please verify if it still should be listed and let me know
> > (either way).
> > 
> > 
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=12499
> > Subject		: Problem with using bluetooth adaper connected to usb port
> > Submitter	: "Maciej Rutecki" <maciej.rutecki@gmail.com>
> > Date		: 2009-01-13 18:34 (84 days old)
> > References	: http://marc.info/?l=linux-kernel&m=123187185426236&w=4
> 
> I prefer to have this checked against 2.6.30-rc1 once Linus released
> that one. I think that I know the root cause for this one and it is
> actually a hardware/firmware bug. Some Bluetooth dongles expect to have
> the interrupt and bulk URBs available at the same time. Otherwise they
> do pee in their pants.
Comment 2 Rafael J. Wysocki 2009-04-26 10:58:58 UTC
Handled-By : Marcel Holtmann <marcel@holtmann.org>
Comment 3 Rafael J. Wysocki 2009-05-17 10:12:55 UTC
On Sunday 17 May 2009, Maciej Rutecki wrote:
> 2009/5/16 Rafael J. Wysocki <rjw@sisk.pl>:
> > This message has been generated automatically as a part of a report
> > of regressions introduced between 2.6.28 and 2.6.29.
> >
> > The following bug entry is on the current list of known regressions
> > introduced between 2.6.28 and 2.6.29.  Please verify if it still should
> > be listed and let me know (either way).
> >
> >
> > Bug-Entry       : http://bugzilla.kernel.org/show_bug.cgi?id=12499
> > Subject         : Problem with using bluetooth adaper connected to usb port
> > Submitter       : Maciej Rutecki <maciej.rutecki@gmail.com>
> > Date            : 2009-01-13 18:34 (124 days old)
> > References      : http://marc.info/?l=linux-kernel&m=123187185426236&w=4
> > Handled-By      : Marcel Holtmann <marcel@holtmann.org>
> >
> 
> 2.6.30-rc6 works fine. Please, remove it.

Note You need to log in before you can comment on or make changes to this bug.