Bug 12498 - OOPS and panic on 2.6.29-rc1 on xen-x86
OOPS and panic on 2.6.29-rc1 on xen-x86
Status: CLOSED CODE_FIX
Product: Memory Management
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: Andrew Morton
:
Depends on:
Blocks: 12398
  Show dependency treegraph
 
Reported: 2009-01-19 14:12 UTC by Rafael J. Wysocki
Modified: 2009-02-03 15:07 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.29-rc1
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-01-19 14:12:56 UTC
Subject    : OOPS and panic on 2.6.29-rc1 on xen-x86
Submitter  : Bryan Donlan <bdonlan@gmail.com>
Date       : 2009-01-12 17:26
References : http://marc.info/?l=linux-kernel&m=123178178029065&w=4
Handled-By : Nick Piggin <npiggin@suse.de>

This entry is being used for tracking a regression from 2.6.28.  Please don't
close it until the problem is fixed in the mainline.

Reportedly caused by:

commit e97a630eb0f5b8b380fd67504de6cedebb489003
Author: Nick Piggin <npiggin@suse.de>
Date:   Tue Jan 6 14:39:19 2009 -0800

    mm: vmalloc use mutex for purge

    Signed-off-by: Nick Piggin <npiggin@suse.de>
    Signed-off-by: Andrew Morton <akpm@linux-foundation.org>
    Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>

First-Bad-Commit : e97a630eb0f5b8b380fd67504de6cedebb489003
Comment 1 Rafael J. Wysocki 2009-02-03 15:06:17 UTC
On Tuesday 20 January 2009, Nick Piggin wrote:
> On Mon, Jan 19, 2009 at 10:32:16PM +0100, Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> > 
> > The following bug entry is on the current list of known regressions
> > from 2.6.28.  Please verify if it still should be listed and let me know
> > (either way).
> > 
> > 
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=12498
> > Subject		: OOPS and panic on 2.6.29-rc1 on xen-x86
> > Submitter	: Bryan Donlan <bdonlan@gmail.com>
> > Date		: 2009-01-12 17:26 (8 days old)
> > First-Bad-Commit: http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=e97a630eb0f5b8b380fd67504de6cedebb489003
> > References	: http://marc.info/?l=linux-kernel&m=123178178029065&w=4
> > Handled-By	: Nick Piggin <npiggin@suse.de>
> > 
> 
> This one was fixed by backing out the patch to make vmalloc purge
> spinlock into a mutex.


Note You need to log in before you can comment on or make changes to this bug.