Bug 12495 - thinkpad problems during resume
thinkpad problems during resume
Status: CLOSED CODE_FIX
Product: Power Management
Classification: Unclassified
Component: cpufreq
All Linux
: P1 normal
Assigned To: cpufreq
:
: 12468 (view as bug list)
Depends on:
Blocks: 7216 12398
  Show dependency treegraph
 
Reported: 2009-01-19 13:11 UTC by Rafael J. Wysocki
Modified: 2009-02-04 17:40 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.29-rc2
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-01-19 13:11:52 UTC
Subject    : 2.6.29-rc1: [SOLVED] thinkpad problems during resume
Submitter  : Christian Borntraeger <borntraeger@de.ibm.com>
Date       : 2009-01-17 15:48
References : http://marc.info/?l=linux-kernel&m=123220746125479&w=4
References : http://marc.info/?l=linux-kernel&m=123170361827197&w=4
Handled-By : Mike Travis <travis@sgi.com>
Patch      : http://lkml.org/lkml/2009/1/16/375
Patch      : http://lkml.org/lkml/2009/1/16/376
Patch      : http://lkml.org/lkml/2009/1/16/378

This entry is being used for tracking a regression from 2.6.28.  Please don't
close it until the problem is fixed in the mainline.

Caused by:

commit e39ad415ac15116df213dfa2aa2a4f1b0857af9c
Author: Mike Travis <travis@sgi.com>
Date:   Sun Jan 4 05:18:10 2009 -0800

    cpumask: use work_on_cpu in acpi-cpufreq.c for read_measured_perf_ctrs

    Signed-off-by: Mike Travis <travis@sgi.com>
    Acked-by: Rusty Russell <rusty@rustcorp.com.au>
    Signed-off-by: Ingo Molnar <mingo@elte.hu>

First-Bad-Commit : e39ad415ac15116df213dfa2aa2a4f1b0857af9c
Comment 1 Len Brown 2009-01-20 13:13:08 UTC
*** Bug 12468 has been marked as a duplicate of this bug. ***
Comment 2 Len Brown 2009-01-20 13:26:45 UTC
I have verified that the three patches above make
a cpufreq-enabled upstream kernel able to resume again on my T61.

I cherry-picked them from Ingo's tree here:

http://git.kernel.org/?p=linux/kernel/git/tip/linux-2.6-tip.git;a=commitdiff;h=31ad9081200c06ccc350625d41d1f8b2d1cef29f

http://git.kernel.org/?p=linux/kernel/git/tip/linux-2.6-tip.git;a=commitdiff;h=8ccad40df8d314f786fdb06bdbedd4f43f3257cd

http://git.kernel.org/?p=linux/kernel/git/tip/linux-2.6-tip.git;a=commitdiff;h=72859081851af2bda04117ca3d64206ffa199e5e

(follow the "raw" link to get the text patch)

While these were necessary, they were not sufficient,
rc2 requires also a USB patch for bug 12422)

Comment 3 Rafael J. Wysocki 2009-02-04 17:00:16 UTC
On Wednesday 04 February 2009, Christian Borntraeger wrote:
> Am Wednesday 04 February 2009 11:23:58 schrieb Rafael J. Wysocki:
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> >
> > The following bug entry is on the current list of known regressions
> > from 2.6.28.  Please verify if it still should be listed and let me know
> > (either way).
> >
> >
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=12495
> > Subject		: thinkpad problems during resume
> > Submitter	: Christian Borntraeger <borntraeger@de.ibm.com>
> > Date		: 2009-01-17 15:48 (19 days old)
> > First-Bad-Commit:
> > http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h
> >=e39ad415ac15116df213dfa2aa2a4f1b0857af9c References	:
> > http://marc.info/?l=linux-kernel&m=123220746125479&w=4
> > http://marc.info/?l=linux-kernel&m=123170361827197&w=4
> > Handled-By	: Mike Travis <travis@sgi.com>
> > Patch		: http://lkml.org/lkml/2009/1/16/375
> > 		  http://lkml.org/lkml/2009/1/16/376
> > 		  http://lkml.org/lkml/2009/1/16/378
> 
> Fixed upstream. 


Note You need to log in before you can comment on or make changes to this bug.