Bug 12457 - IBM X40 laptop does no longer resume
IBM X40 laptop does no longer resume
Status: RESOLVED DUPLICATE of bug 12422
Product: Drivers
Classification: Unclassified
Component: USB
All Linux
: P1 normal
Assigned To: Greg Kroah-Hartman
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-16 01:52 UTC by Daniel Vetter
Modified: 2009-01-16 08:09 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.29-rc1
Tree: Mainline
Regression: Yes


Attachments
full dmesg of the last working rev with a suspend/resume cycle (53.14 KB, text/plain)
2009-01-16 01:54 UTC, Daniel Vetter
Details

Description Daniel Vetter 2009-01-16 01:52:37 UTC
Latest working kernel version:2.6.28
Distribution: Debian unstable x86 32bit
Hardware Environment: Thinkpad X40 1.5GB mem, 1.2GHz Pentium M
Software Environment: Using the debian hibernate scripts.

When trying to resume from suspend-to-ram (via opening the lid), the system hangs after turning on the cpu fan and the display backlight. The suspend-indicator-led still shines. System is totally unresponsive, not even SysRq can reboot it. But vga console seems to work, at least I can see the blinking cursor. The only way to get out is to hold the power button for a few secs.

git bisect points to:

commit a0d4922da2e4ccb0973095d8d29f36f6b1b5f703
Author: Alan Stern <stern@rowland.harvard.edu>
Date:   Wed Dec 17 15:06:03 2008 -0500

    USB: fix up suspend and resume for PCI host controllers

I'll now test whether reverting this commit helps. btw, there's nothing connected to the usb bus besides the integrated bluetooth. Turning this off (ie. disconnecting via firmwire-controlled keys) doesn't change anything in the results.
Comment 1 Daniel Vetter 2009-01-16 01:54:43 UTC
Created attachment 19827 [details]
full dmesg of the last working rev with a suspend/resume cycle
Comment 2 Daniel Vetter 2009-01-16 03:00:53 UTC
I've just tested v2.6.29-rc1-224-ga652504 with a0d4922da2e4c reverted. Worked flawless for a few suspend/resume cycles. So bisecting has really found the culprit.
Comment 3 Alan Stern 2009-01-16 07:25:19 UTC
This bug report should be rejected as a duplicate of Bug #12422 (although the commentary in that report is not particularly useful -- see the email thread about it on LKML).

The suggested fix is here:

    http://marc.info/?l=linux-kernel&m=123184641714487&w=2
Comment 4 Daniel Vetter 2009-01-16 08:09:58 UTC
Fix confirmed and bug marked as a duplicate like suggested. Thanks Alan for the pointer (I only looked in the usb section of bz for other reports, because from my pov it was clearly a usb problem).

-Daniel

*** This bug has been marked as a duplicate of bug 12422 ***

Note You need to log in before you can comment on or make changes to this bug.