Bug 12444 - X hangs following switch from radeonfb console - Bisected
X hangs following switch from radeonfb console - Bisected
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel)
All Linux
: P1 normal
Assigned To: drivers_video-dri
:
Depends on:
Blocks: 12398
  Show dependency treegraph
 
Reported: 2009-01-13 14:03 UTC by Graham Murray
Modified: 2009-03-15 03:46 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.29-rc1
Tree: Mainline
Regression: Yes


Attachments
Xorg log following failure (43.65 KB, text/x-log)
2009-01-13 14:04 UTC, Graham Murray
Details

Description Graham Murray 2009-01-13 14:03:48 UTC
Latest working kernel version:2.6.28
Earliest failing kernel version:2.6.29-rc1
Distribution:Gentoo
Hardware Environment:Core2 duo 6700, Radeon X300
Software Environment: Xorg-x11 7.4, xf86-video-ati 6.10, kde-4.1.3, libx11 1.1.5
Problem Description: On switching from KDE-4 with desktop effects enabled to 'text' console and back leave X hung with top, approximately 1/3, of screen corrupted, keyboard and mouse are unresponsive. SAK K returns to kdm login screen. If desktop effects are not enabled, all works OK. 

I have bisected the problem and the commit which introduces it is 7c1c2871a6a3a114853ec6836e9035ac1c0c7f7a drm: move to kref per-master structures.

Steps to reproduce:Configure kernel for radeonfb, 
Start KDE with desktop effects enabled
Switch to 'text' console and back to X
Top, approximately 1/3, of screen is corrupted, keyboard and mouse are unresponsive. SAK K returns to kdm login screen.
Comment 1 Graham Murray 2009-01-13 14:04:46 UTC
Created attachment 19778 [details]
Xorg log following failure
Comment 2 Rafael J. Wysocki 2009-01-13 15:24:34 UTC
First-Bad-Commit : 7c1c2871a6a3a114853ec6836e9035ac1c0c7f7a
Comment 3 Rafael J. Wysocki 2009-02-16 13:51:22 UTC
On Monday 16 February 2009, Graham Murray wrote:
> "Rafael J. Wysocki" <rjw@sisk.pl> writes:
> 
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> >
> > The following bug entry is on the current list of known regressions
> > from 2.6.28.  Please verify if it still should be listed and let me know
> > (either way).
> >
> >
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=12444
> > Subject		: X hangs following switch from radeonfb console - Bisected
> > Submitter	: Graham Murray <graham@gmurray.org.uk>
> > Date		: 2009-01-13 14:03 (33 days old)
> > First-Bad-Commit: http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=7c1c2871a6a3a114853ec6836e9035ac1c0c7f7a
> 
> I am still seeing the problem with 2.6.29-rc5

Comment 4 Rafael J. Wysocki 2009-02-16 13:51:39 UTC
Caused by:

commit 7c1c2871a6a3a114853ec6836e9035ac1c0c7f7a
Author: Dave Airlie <airlied@redhat.com>
Date:   Fri Nov 28 14:22:24 2008 +1000

    drm: move to kref per-master structures.

    Signed-off-by: Dave Airlie <airlied@redhat.com>
Comment 5 Rafael J. Wysocki 2009-02-16 13:52:06 UTC
First-Bad-Commit : 7c1c2871a6a3a114853ec6836e9035ac1c0c7f7a
Comment 6 Rafael J. Wysocki 2009-03-07 15:03:56 UTC
On Saturday 07 March 2009, Graham Murray wrote:
> "Rafael J. Wysocki" <rjw@sisk.pl> writes:
> 
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> >
> > The following bug entry is on the current list of known regressions
> > from 2.6.28.  Please verify if it still should be listed and let me know
> > (either way).
> >
> >
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=12444
> > Subject		: X hangs following switch from radeonfb console - Bisected
> > Submitter	: Graham Murray <graham@gmurray.org.uk>
> > Date		: 2009-01-13 14:03 (50 days old)
> 
> I am still seeing the same symptoms in 2.6.29-rc7-0003-g559595a.

Comment 7 Rafael J. Wysocki 2009-03-15 03:46:04 UTC
On Sunday 15 March 2009, Graham Murray wrote:
> I am no longer seeing this problem with 2.6.29-rc8-00090g326d851, but I
> have also upgrade various parts of X including the radeon driver to
> version 6.12.0. 
> 
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> >
> > The following bug entry is on the current list of known regressions
> > from 2.6.28.  Please verify if it still should be listed and let me know
> > (either way).
> >
> >
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=12444
> > Subject		: X hangs following switch from radeonfb console - Bisected
> > Submitter	: Graham Murray <graham@gmurray.org.uk>
> > Date		: 2009-01-13 14:03 (61 days old)


Note You need to log in before you can comment on or make changes to this bug.