Bug 12426 - TMDC Joystick no longer works in kernel 2.6.28
TMDC Joystick no longer works in kernel 2.6.28
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Input Devices
All Linux
: P1 normal
Assigned To: Dmitry Torokhov
:
Depends on:
Blocks: 11808
  Show dependency treegraph
 
Reported: 2009-01-11 04:58 UTC by Rafael J. Wysocki
Modified: 2009-04-19 10:14 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.28
Tree: Mainline
Regression: Yes


Attachments
Fix gameport driver binding (2.10 KB, patch)
2009-04-12 02:47 UTC, Dmitry Torokhov
Details | Diff

Description Rafael J. Wysocki 2009-01-11 04:58:58 UTC
Subject    : TMDC Joystick no longer works in kernel 2.6.28
Submitter  : "Andrew S. Johnson" <andy@asjohnson.com>
Date       : 2009-01-10 21:53
References : http://marc.info/?l=linux-kernel&m=123162486415366&w=4

This entry is being used for tracking a regression from 2.6.27.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2009-02-04 17:34:08 UTC
On Wednesday 04 February 2009, Jiri Kosina wrote:
> On Wed, 4 Feb 2009, Rafael J. Wysocki wrote:
> 
> > This message has been generated automatically as a part of a report
> > of regressions introduced between 2.6.27 and 2.6.28.
> > 
> > The following bug entry is on the current list of known regressions
> > introduced between 2.6.27 and 2.6.28.  Please verify if it still should
> > be listed and let me know (either way).
> > 
> > 
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=12426
> > Subject		: TMDC Joystick no longer works in kernel 2.6.28
> > Submitter	: Andrew S. Johnson <andy@asjohnson.com>
> > Date		: 2009-01-10 21:53 (26 days old)
> > References	: http://marc.info/?l=linux-kernel&m=123162486415366&w=4
> 
> I asked [1] the Submitter some time ago to check whether reverting a 
> particular commit fixes the issue, but never heard back.
> 
> [1] http://lkml.org/lkml/2009/1/26/70

Comment 2 Pantelis Koukousoulas 2009-03-10 08:20:09 UTC
Hi, this bug affects me too, reverting 6902c0bead4c fixes the issue for me.
Comment 3 Rafael J. Wysocki 2009-03-14 14:24:49 UTC
Caused by:

commit 6902c0bead4ce266226fc0c5b3828b850bdc884a
Author: Dmitry Torokhov <dmitry.torokhov@gmail.com>
Date:   Fri Jun 6 01:33:22 2008 -0400

    Input: gameport - make gameport_register_driver() return errors

    Perform actual driver registration right in gameport_register_driver()
    instead of offloading it to kgameportd and return proper error code to
    callers if driver registration fails.

    Note that driver <-> port matching is still done by kgameportd.

    Signed-off-by: Dmitry Torokhov <dtor@mail.ru>

First-Bad-Commit : 6902c0bead4ce266226fc0c5b3828b850bdc884a
Comment 4 Dmitry Torokhov 2009-04-12 02:47:27 UTC
Created attachment 20942 [details]
Fix gameport driver binding

I think this should fix the problem, it would be great if you could test it. Thanks!
Comment 5 Pantelis Koukousoulas 2009-04-13 07:31:53 UTC
I 'll try to test it soon, thanks :)
Comment 6 Pantelis Koukousoulas 2009-04-16 10:05:36 UTC
On Mon, Apr 13, 2009 at 10:31 AM, Pantelis Koukousoulas
<pktoss@gmail.com> wrote:
> I 'll try to test it soon, thanks :)
>

Sorry for taking so long to test, it looks like 2.6.29 broke my
pxeboot/nfsroot setup with the test machine.
But 2.6.29-rc6 works, so:

Test sequence:
1) boot with snd_ens1371 blacklisted so that it doesn't load
2) modprobe snd_ens1371 joystick_port=1
    modprobe analog
    modprobe joydev
3) look for existence of /dev/input/js0

Results:

Vanilla 2.6.29-rc6: the problem is still there. No /dev/input/js0 device.

Vanilla 2.6.29-rc6 + dmitry's patch: /dev/input/js0 shows up as expected.

So, as far as I 'm concerned the problem is fixed.

You can add tested-by: Pantelis Koukousoulas <pktoss@gmail.com> if that helps.
Comment 7 Dmitry Torokhov 2009-04-18 23:30:18 UTC
The patch is in mainline, shoudl appear in 2.6.30-rc3; closing.

Note You need to log in before you can comment on or make changes to this bug.