Bug 12422 - 2.6.28-git can't resume from str
2.6.28-git can't resume from str
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: USB
All Linux
: P1 normal
Assigned To: Greg Kroah-Hartman
:
: 12457 (view as bug list)
Depends on:
Blocks: 7216 12398
  Show dependency treegraph
 
Reported: 2009-01-10 17:19 UTC by Rafael J. Wysocki
Modified: 2009-02-03 15:02 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.28-git
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-01-10 17:19:46 UTC
Subject    : 2.6.28-git can't resume from str
Submitter  : "Jeff Chua" <jeff.chua.linux@gmail.com>
Date       : 2009-01-10 1:39
References : http://marc.info/?l=linux-kernel&m=123155157909282&w=4

This entry is being used for tracking a regression from 2.6.28.  Please don't
close it until the problem is fixed in the mainline.

Reportedly introduced by:

commit e3f47f89a57ef115755184a8b3f03a47ee227418
Author: Daniel Drake <dsd@gentoo.org>
Date:   Wed Dec 10 23:28:25 2008 +0200

    USB: unusual_devs.h additions for Pentax K10D

    Signed-off-by: Daniel Drake <dsd@gentoo.org>
    Signed-off-by: Phil Dibowitz <phil@ipom.com>
Comment 1 Pavel Machek 2009-01-14 13:45:05 UTC
The commit e3f47f89a57ef115755184a8b3f03a47ee227418 is very simple:

--- a/drivers/usb/storage/unusual_devs.h
+++ b/drivers/usb/storage/unusual_devs.h
@@ -1320,6 +1320,13 @@ UNUSUAL_DEV( 0x0840, 0x0082, 0x0001, 0x0
                US_SC_DEVICE, US_PR_DEVICE, NULL,
                US_FL_FIX_CAPACITY),
 
+/* Reported and patched by Nguyen Anh Quynh <aquynh@gmail.com> */
+UNUSUAL_DEV( 0x0840, 0x0084, 0x0001, 0x0001,
+               "Argosy",
+               "Storage",
+               US_SC_DEVICE, US_PR_DEVICE, NULL,
+               US_FL_FIX_CAPACITY),
+
 /* Entry and supporting patch by Theodore Kilgore <kilgota@auburn.edu>.
  * Flag will support Bulk devices which use a standards-violating 32-byte
  * Command Block Wrapper. Here, the "DC2MEGA" cameras (several brands) with


...I'm pretty sure it does not break anything. I tried reverting it, but...

Comment 2 Daniel Vetter 2009-01-16 08:09:58 UTC
*** Bug 12457 has been marked as a duplicate of this bug. ***
Comment 3 Rafael J. Wysocki 2009-01-19 12:19:39 UTC
In fact the cause of this problem is:

commit a0d4922da2e4ccb0973095d8d29f36f6b1b5f703
Author: Alan Stern <stern@rowland.harvard.edu>
Date:   Wed Dec 17 15:06:03 2008 -0500

    USB: fix up suspend and resume for PCI host controllers

    Signed-off-by: Alan Stern <stern@rowland.harvard.edu>
    CC: Rafael J. Wysocki <rjw@sisk.pl>
    Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>

First-Bad-Commit : a0d4922da2e4ccb0973095d8d29f36f6b1b5f703
Comment 4 Rafael J. Wysocki 2009-01-19 12:22:19 UTC
Handled-By : Rafael J. Wysocki <rjw@sisk.pl>
Patch : http://lkml.org/lkml/2009/1/13/144
Comment 5 Rafael J. Wysocki 2009-01-19 13:15:56 UTC
References : http://marc.info/?l=linux-kernel&m=123167815028388&w=4

Note You need to log in before you can comment on or make changes to this bug.