Bug 12421 - GPF on 2.6.28 and 2.6.28-rc9-git3, e1000e and e1000 issues
GPF on 2.6.28 and 2.6.28-rc9-git3, e1000e and e1000 issues
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Network
All Linux
: P1 normal
Assigned To: Jesse Brandeburg
:
Depends on:
Blocks: 11808
  Show dependency treegraph
 
Reported: 2009-01-10 17:15 UTC by Rafael J. Wysocki
Modified: 2010-09-03 09:09 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.28
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-01-10 17:15:15 UTC
Subject    : GPF on 2.6.28 & 2.6.28-rc9-git3    e1000e / e1000 issues
Submitter  : "Doug Bazarnic" <doug@bazarnic.net>
Date       : 2009-01-09 21:26
References : http://marc.info/?l=linux-kernel&m=123153653120204&w=4

This entry is being used for tracking a regression from 2.6.27.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Jesse Brandeburg 2009-02-20 15:40:30 UTC
want to try the map/unmap fixes I posted to 
doug do you want to try the unmap fixes I posted to http://bugzilla.kernel.org/show_bug.cgi?id=12404

Not sure if they are related to this one, it seems kind of vaguely related.
Comment 2 Jesse Brandeburg 2009-04-28 19:28:06 UTC
proposed fixes was commited by linus on 20090403 in 
e1000: 37e73df8c3f19f4733c60ec53c104ff6f79ba467
       d20b606c99c7fd9f1b6c6ec43c877eaae827d169

and
e1000e: 1b7719c4559dc1522065d4cfd033f8bb8f969159
        8ddc951c73cbc317148c0b9973dde81eece57e4c

and:
igb: 65689fef7e484631e996541a6772706627b0991a

ixgb: fe52eeb82b746de441ed27c54ace940efe86bc9a
      
ixgbe: 44df32c592f5a626c9f2ed56642e939788022408

all was included in 2.6.30-rc1 (AFAIK)

still waiting on NEEDINFO
Comment 3 Florian Mickler 2010-09-03 09:09:02 UTC
I'm closing this then. 

Please reopen if this issue persists.

Note You need to log in before you can comment on or make changes to this bug.