Bug 12420 - WARNING: at drivers/ata/libata-sff.c:1017 ata_sff_hsm_move+0x45e/0x750()
WARNING: at drivers/ata/libata-sff.c:1017 ata_sff_hsm_move+0x45e/0x750()
Status: CLOSED CODE_FIX
Product: IO/Storage
Classification: Unclassified
Component: Serial ATA
All Linux
: P1 normal
Assigned To: Jeff Garzik
:
Depends on:
Blocks: 12398
  Show dependency treegraph
 
Reported: 2009-01-10 17:09 UTC by Rafael J. Wysocki
Modified: 2009-01-14 02:58 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.28-self-07939-g2150edc
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-01-10 17:09:53 UTC
Subject    : todays git: WARNING: at drivers/ata/libata-sff.c:1017 ata_sff_hsm_move+0x45e/0x750()
Submitter  : Christian Borntraeger <borntraeger@de.ibm.com>
Date       : 2009-01-09 12:34
References : http://marc.info/?l=linux-kernel&m=123150457832109&w=4
Notify-Also : Sergei Shtylyov <sshtylyov@ru.mvista.com>
Notify-Also : Ingo Molnar <mingo@elte.hu>

This entry is being used for tracking a regression from 2.6.28.  Please don't
close it until the problem is fixed in the mainline.

Introduced by:

commit 871af1210f13966ab911ed2166e4ab2ce775b99d
Author: Alan Cox <alan@redhat.com>
Date:   Mon Jan 5 14:16:39 2009 +0000

    libata: Add 32bit PIO support

    Signed-off-by: Alan Cox <alan@redhat.com>
    Signed-off-by: Jeff Garzik <jgarzik@redhat.com>

First-Bad-Commit : 871af1210f13966ab911ed2166e4ab2ce775b99d
Comment 1 Alex Riesen 2009-01-11 15:07:35 UTC
Me too. Dell XPS M1330, v2.6.29-rc1:

WARNING: at drivers/ata/libata-sff.c:1017 ata_sff_hsm_move+0x4d5/0x73a()
Hardware name: XPS M1330                       
Modules linked in:
Pid: 0, comm: swapper Not tainted 2.6.29-rc1-t #155
Call Trace:
 <IRQ>  [<ffffffff8023c2e8>] warn_slowpath+0xd8/0x114
 [<ffffffff8025df86>] ? get_lock_stats+0x2d/0x5c
 [<ffffffff8025dfc3>] ? put_lock_stats+0xe/0x27
 [<ffffffff8025df86>] ? get_lock_stats+0x2d/0x5c
 [<ffffffff80211c41>] ? native_sched_clock+0x49/0x75
 [<ffffffff80211c41>] ? native_sched_clock+0x49/0x75
 [<ffffffff80211c41>] ? native_sched_clock+0x49/0x75
 [<ffffffff80447a22>] ? ata_sff_data_xfer32+0x67/0xab
 [<ffffffff8025df86>] ? get_lock_stats+0x2d/0x5c
 [<ffffffff804472f1>] ata_sff_hsm_move+0x4d5/0x73a
 [<ffffffff80447825>] ata_sff_interrupt+0x199/0x241
 [<ffffffff8027087c>] handle_IRQ_event+0x28/0x60
 [<ffffffff80271d6e>] handle_edge_irq+0xfe/0x14d
 [<ffffffff805cd2c3>] __irqentry_text_start+0xfb/0x17f
 [<ffffffff8020c293>] ret_from_intr+0x0/0xf
 <EOI> <4>---[ end trace 84b989cd0972d1c4 ]---
isa bounce pool size: 16 pages
scsi 3:0:0:0: CD-ROM            HL-DT-ST DVDRW  GSA-S10N  A100 PQ: 0 ANSI: 5
sr0: scsi3-mmc drive: 24x/24x writer cd/rw xa/form2 cdda caddy
Comment 2 Alan 2009-01-14 02:42:51 UTC
bogus warning removed

Note You need to log in before you can comment on or make changes to this bug.