Bug 12418 - Repeated ioctl(4, 0x40046445, ..) loop in glxgears
Repeated ioctl(4, 0x40046445, ..) loop in glxgears
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel)
All Linux
: P1 normal
Assigned To: drivers_video-dri
:
Depends on:
Blocks: 12398
  Show dependency treegraph
 
Reported: 2009-01-10 16:52 UTC by Rafael J. Wysocki
Modified: 2009-03-16 14:28 UTC (History)
2 users (show)

See Also:
Kernel Version: commit 7c1c2871a6a3a114853ec6836e9035ac1c0c7f7a
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-01-10 16:52:48 UTC
Subject    : Re: [regression] glx performance drop with: "x86: PAT: implement track/untrack of pfnmap regions for x86 - v3"
Submitter  : "Pallipadi, Venkatesh" <venkatesh.pallipadi@intel.com>
Date       : 2009-01-07 22:43
References : http://marc.info/?l=linux-kernel&m=123136836213319&w=4

This entry is being used for tracking a regression from 2.6.28.  Please don't
close it until the problem is fixed in the mainline.

Introduced by:

commit 7c1c2871a6a3a114853ec6836e9035ac1c0c7f7a
Author: Dave Airlie <airlied@redhat.com>
Date:   Fri Nov 28 14:22:24 2008 +1000

    drm: move to kref per-master structures.

    Signed-off-by: Dave Airlie <airlied@redhat.com>

First-Bad-Commit : 7c1c2871a6a3a114853ec6836e9035ac1c0c7f7a
Comment 1 Venkatesh Pallipadi 2009-03-16 11:16:52 UTC
Looks like problem is gone with latest git (5bee17f).
Not sure what commit fixed this problem. Please close this bug.

Note You need to log in before you can comment on or make changes to this bug.