Bug 12412 - Regression in v2.6.28 introduced by: 'USB: skip Set-Interface(0) if already in altsetting 0'
Regression in v2.6.28 introduced by: 'USB: skip Set-Interface(0) if already i...
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: USB
All Linux
: P1 normal
Assigned To: Greg Kroah-Hartman
:
Depends on:
Blocks: 11808
  Show dependency treegraph
 
Reported: 2009-01-10 16:14 UTC by Rafael J. Wysocki
Modified: 2009-01-12 14:50 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.28
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-01-10 16:14:38 UTC
Subject    : [BUG] Regression in v2.6.28 introduced by: 'USB: skip Set-Interface(0) if already in altsetting 0'
Submitter  : Jan Scholz <scholz@fias.uni-frankfurt.de>
Date       : 2009-01-02 11:04
References : http://marc.info/?l=linux-kernel&m=123089613601599&w=4

This entry is being used for tracking a regression from 2.6.27.  Please don't
close it until the problem is fixed in the mainline.

Introduced by:

commit 24c0996a6b73e2554104961afcc8659534503e0d
Author: Alan Stern <stern@rowland.harvard.edu>
Date:   Mon Dec 1 10:24:41 2008 -0500

    USB: skip Set-Interface(0) if already in altsetting 0

    Signed-off-by: Alan Stern <stern@rowland.harvard.edu>
    Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>

First-Bad-Commit : 24c0996a6b73e2554104961afcc8659534503e0d
Comment 1 Erik Ekman 2009-01-11 12:59:53 UTC
See if the patch to #12301 helps. That fix is in mainline now.
Comment 2 Alan Stern 2009-01-12 14:01:58 UTC
On Sat, 10 Jan 2009 bugme-daemon@bugzilla.kernel.org wrote:

> http://bugzilla.kernel.org/show_bug.cgi?id=12412
> 
>            Summary: Regression in v2.6.28 introduced by: 'USB: skip Set-
>                     Interface(0) if already in altsetting 0'

Fixed by commit: 2caf7fcdb8532045680f06b67b9e63f0c9613aaa

Alan Stern


Note You need to log in before you can comment on or make changes to this bug.