Bug 12409 - NULL pointer dereference at get_stats()
NULL pointer dereference at get_stats()
Status: RESOLVED DOCUMENTED
Product: Networking
Classification: Unclassified
Component: IPV4
All Linux
: P1 normal
Assigned To: Stephen Hemminger
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-10 15:38 UTC by Rafael J. Wysocki
Modified: 2009-03-26 16:14 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.28
Tree: Mainline
Regression: Yes


Attachments
debug patch to print driver (1.43 KB, text/x-diff)
2009-01-14 12:18 UTC, Stephen Hemminger
Details

Description Rafael J. Wysocki 2009-01-10 15:38:07 UTC
Subject    : [2.6.28] NULL pointer dereference at get_stats()
Submitter  : Tetsuo Handa <penguin-kernel@i-love.sakura.ne.jp>
Date       : 2008-12-30 12:53
References : http://marc.info/?l=linux-kernel&m=123064167008695&w=4
Handled-By : Frederik Deweerdt <frederik.deweerdt@xprog.eu>

This entry is being used for tracking a regression from 2.6.27.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Thomas Gleixner 2009-01-14 05:30:12 UTC
This happens in the networking code:

EIP is at get_stats+0x1d/0x48
...
[<c05bcc0f>] dev_seq_show+0x1c/0x77

EIP is at get_stats+0x1d/0x48
...
 [<c05c571a>] rtnl_fill_ifinfo+0x2c9/0x498

Reassigning to networking
Comment 2 Stephen Hemminger 2009-01-14 12:18:53 UTC
Created attachment 19798 [details]
debug patch to print driver
Comment 3 Stephen Hemminger 2009-01-14 12:19:05 UTC
Some network driver has incorrectly cleared the get_stats function pointer.
We need more information to figure out which driver is involved.
See attached patch which will print error.

Because things are done in differently in 2.6.29, this will no longer happen.

Note You need to log in before you can comment on or make changes to this bug.