Bug 12404 - Oops in 2.6.28-rc9 and -rc8 -- mtrr issues / e1000e
Oops in 2.6.28-rc9 and -rc8 -- mtrr issues / e1000e
Status: RESOLVED CODE_FIX
Product: Platform Specific/Hardware
Classification: Unclassified
Component: x86-64
All Linux
: P1 normal
Assigned To: Jesse Brandeburg
:
Depends on:
Blocks: 11808
  Show dependency treegraph
 
Reported: 2009-01-10 14:08 UTC by Rafael J. Wysocki
Modified: 2009-04-28 19:26 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.28-rc8
Tree: Mainline
Regression: Yes


Attachments
unmap fixes for e1000e (3.94 KB, patch)
2009-02-20 15:36 UTC, Jesse Brandeburg
Details | Diff

Description Rafael J. Wysocki 2009-01-10 14:08:09 UTC
Subject    : Oops in 2.6.28-rc9 and -rc8 -- mtrr issues / e1000e
Submitter  : "Kernel" <kernel@bazarnic.net>
Date       : 2008-12-22 9:37
References : http://marc.info/?l=linux-kernel&m=122993873320150&w=4

This entry is being used for tracking a regression from 2.6.27.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Yinghai Lu 2009-01-14 13:45:54 UTC
can you post cat /proc/mtrr?
Comment 2 Jesse Brandeburg 2009-02-20 15:36:25 UTC
Created attachment 20319 [details]
unmap fixes for e1000e

Please original reporter or anyone else tracking this try this patch.  We have a similar one for the unmap issue for e1000.  They are both not doing map/unmap symmetrically for some transmit buffers.
Comment 3 Jesse Brandeburg 2009-04-28 19:26:04 UTC
was commited by linus on 20090403 in 
e1000: 37e73df8c3f19f4733c60ec53c104ff6f79ba467
       d20b606c99c7fd9f1b6c6ec43c877eaae827d169

and
e1000e: 1b7719c4559dc1522065d4cfd033f8bb8f969159
        8ddc951c73cbc317148c0b9973dde81eece57e4c

and:
igb: 65689fef7e484631e996541a6772706627b0991a

ixgb: fe52eeb82b746de441ed27c54ace940efe86bc9a
      
ixgbe: 44df32c592f5a626c9f2ed56642e939788022408

all was included in 2.6.30-rc1 (AFAIK)

Note You need to log in before you can comment on or make changes to this bug.