Bug 12401 - 2.6.28 regression: xbacklight broken on ThinkPad X61s
2.6.28 regression: xbacklight broken on ThinkPad X61s
Status: CLOSED DOCUMENTED
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel)
All Linux
: P1 normal
Assigned To: Tino Keitel
:
: 12361 (view as bug list)
Depends on:
Blocks: 11808 56331
  Show dependency treegraph
 
Reported: 2009-01-10 13:45 UTC by Rafael J. Wysocki
Modified: 2013-04-09 06:23 UTC (History)
7 users (show)

See Also:
Kernel Version: 2.6.28
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-01-10 13:45:57 UTC
Subject    : 2.6.28 regression: xbacklight broken on ThinkPad X61s
Submitter  : Tino Keitel <tino.keitel@gmx.de>
Date       : 2009-01-05 8:39
References : http://marc.info/?l=linux-kernel&m=123114479110314&w=4

This entry is being used for tracking a regression from 2.6.27.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2009-01-10 13:46:35 UTC
Notify-Also : Zhang Rui <rui.zhang@intel.com>
Notify-Also : Matthew Garrett <mjg59@srcf.ucam.org>
Comment 2 Rafael J. Wysocki 2009-01-10 13:48:17 UTC
Exposed by:

commit 22c13f9d8179f4c9caecfcb60a95214562b9addc
Author: Thomas Renninger <trenn@suse.de>
Date:   Fri Aug 1 17:37:54 2008 +0200

    ACPI: video: Ignore devices that aren't present in hardware

    Signed-off-by: Thomas Renninger <trenn@suse.de>
    Acked-by: Zhang Rui <rui.zhang@intel.com>
    Signed-off-by: Andi Kleen <ak@linux.intel.com>
    Signed-off-by: Len Brown <len.brown@intel.com>

First-Bad-Commit : 22c13f9d8179f4c9caecfcb60a95214562b9addc
Comment 3 Yves-Alexis Perez 2009-01-10 14:40:54 UTC
On my T61 2.6.28 is the kernel which made the brightness keys work :) The OpRegion stuff fixed all for me, and xbacklight works fine too. So maybe there's some stuff missing for x61 but on other X3100 it's working.

Cheers,
Comment 4 Erik Ekman 2009-01-11 13:07:24 UTC
This looks like a duplicate of #12361.
Comment 5 Zhang Rui 2009-01-11 17:45:44 UTC
*** Bug 12361 has been marked as a duplicate of this bug. ***
Comment 6 Matthias Heinz 2009-01-20 00:08:30 UTC
Bug 12174 could also be a duplicate.
Comment 7 Thomas Renninger 2009-02-04 08:37:31 UTC
I remember Matthew and Rui saying that OpRegion does not always work due to IRQ problems with the Intel graphics driver? But I don't know how to find that out or how far it is solved. Hmm, Matthew does not have a bugzilla account...

Matthias: Can you switch brightness by echoing brightness levels into the remaining backlight device's sysfs files?
Comment 8 Zhang Rui 2009-02-04 17:20:08 UTC
Tino, please attach the acpidump output.
you can get it by using the latest pmtools at http://www.lesswatts.org/projects/acpi/utilities.php
Comment 9 Matthew Garrett 2009-02-04 17:26:39 UTC
If this is still a problem, I strongly suspect that it's down to the 915 drm failing to get the IRQs. This has been a perennial problem - it's been fixed at various points.

However, the ACPI change means that that systems that expect opregion support *must* have the i915 drm loaded to get working brightness control.
Comment 10 Tino Keitel 2009-02-04 23:30:29 UTC
The acpidump output is attached to bug #12361
Comment 11 Tino Keitel 2009-02-04 23:33:10 UTC
If drm must be loaded, then this could be the real cause why xbacklight is not working, and why it worked the last time I tried 2.6.28.2. I disable drm most of the time, because it saves some power, and the X61s is a small and mobile laptop.

Comment 12 Matthew Garrett 2009-02-05 08:24:58 UTC
Oh, right. There's no way to make this work correctly without drm. Can you try with that built?
Comment 13 Zhang Rui 2009-02-23 23:20:02 UTC
I guess this problem can also be fixed by the patch in http://bugzilla.kernel.org/show_bug.cgi?id=11259#c26
matthow, right?
Comment 14 Matthew Garrett 2009-02-24 02:42:52 UTC
No. This bug relates to the fact that the DRM code is now required for working backlight control on some i915 machines.
Comment 15 Zhang Rui 2009-02-24 17:56:30 UTC
oops, sorry
first, I mean the patch in comment#25 bug#11259.
second, what we need is that i915 driver MUST be loaded on IGD OpRegion boxes to support backlight control, which the patch in comment#25 bug#11259 is not(it only fixes the oops when KMS is set).

well, I don't think we got a proposal for this bug in the IRC yesterday.
Matthew, any ideas?
Comment 16 Matthew Garrett 2009-02-24 17:58:48 UTC
If users with opregion-based hardware don't build the i915 DRM they don't get backlight control. I don't think there's any other way of dealing with this. Distros will all be building with DRM, so I don't think it's a real problem.
Comment 17 Zhang Rui 2009-02-24 18:04:40 UTC
sounds good.

close this bug as the backlight works if DRM is loaded (comment #11).

Note You need to log in before you can comment on or make changes to this bug.