Bug 12399 - USB wakeup problem on multiple machines
USB wakeup problem on multiple machines
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: USB
All Linux
: P1 normal
Assigned To: Greg Kroah-Hartman
:
Depends on:
Blocks: 7216 12398
  Show dependency treegraph
 
Reported: 2009-01-10 13:30 UTC by Rafael J. Wysocki
Modified: 2009-02-04 04:37 UTC (History)
2 users (show)

See Also:
Kernel Version: commit 6fd9086a518d4f14213a32fe6c9ac17fabebbc1e
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-01-10 13:30:36 UTC
Subject    : [Regression] USB wakeup problem on Toshiba Portege R500
Submitter  : "Rafael J. Wysocki" <rjw@sisk.pl>
Date       : 2009-01-08 7:35
References : http://marc.info/?l=linux-kernel&m=123140019117968&w=4

This entry is being used for tracking a regression from 2.6.27.  Please don't
close it until the problem is fixed in the mainline.

Caused by:

commit 6fd9086a518d4f14213a32fe6c9ac17fabebbc1e
Author: Alan Stern <stern@rowland.harvard.edu>
Date:   Wed Dec 17 17:20:38 2008 -0500

    USB: automatically enable wakeup for PCI host controllers

    Signed-off-by: Alan Stern <stern@rowland.harvard.edu>
    Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>

First-Bad-Commit : 6fd9086a518d4f14213a32fe6c9ac17fabebbc1e
Comment 1 Rafael J. Wysocki 2009-01-10 13:31:04 UTC
Should be "a regression from 2.6.28", sorry.
Comment 2 Rafael J. Wysocki 2009-01-19 12:25:33 UTC
Handled-By : Alan Stern <stern@rowland.harvard.edu>
Patch : http://marc.info/?l=linux-usb&m=123186456612410&w=4

Note You need to log in before you can comment on or make changes to this bug.