Bug 12395 - 2.6.28-rc9: oprofile regression
2.6.28-rc9: oprofile regression
Status: CLOSED CODE_FIX
Product: Platform Specific/Hardware
Classification: Unclassified
Component: x86-64
All Linux
: P1 normal
Assigned To: platform_x86_64@kernel-bugs.osdl.org
:
Depends on:
Blocks: 11808
  Show dependency treegraph
 
Reported: 2009-01-09 15:16 UTC by Rafael J. Wysocki
Modified: 2009-03-07 14:16 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.28-rc9
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2009-01-09 15:16:21 UTC
Subject    : 2.6.28-rc9: oprofile regression
Submitter  : Tim Blechmann <tim@klingt.org>
Date       : 2008-12-21 14:23
References : http://marc.info/?l=linux-kernel&m=122986946614791&w=4
Handled-By : Andi Kleen <ak@linux.intel.com>

This entry is being used for tracking a regression from 2.6.27.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2009-01-09 15:18:07 UTC
Reportedly caused by:

commit b99170288421c79f0c2efa8b33e26e65f4bb7fb8
Author: Andi Kleen <ak@linux.intel.com>
Date:   Mon Aug 18 14:50:31 2008 +0200

    oprofile: Implement Intel architectural perfmon support

    Signed-off-by: Andi Kleen <ak@linux.intel.com>
    Signed-off-by: Robert Richter <robert.richter@amd.com>

First-Bad-Commit: b99170288421c79f0c2efa8b33e26e65f4bb7fb8
Comment 2 tim blechmann 2009-02-24 03:20:59 UTC
patch at:
http://marc.info/?l=linux-kernel&m=123506131927371&w=4
Comment 3 Rafael J. Wysocki 2009-02-25 14:33:54 UTC
Handled-By : Tim Blechmann <tim@klingt.org>
Patch : http://marc.info/?l=linux-kernel&m=123506131927371&w=4
Comment 4 Rafael J. Wysocki 2009-03-07 14:15:50 UTC
On Wednesday 04 March 2009, Ingo Molnar wrote:
> 
> * Ingo Molnar <mingo@elte.hu> wrote:
> 
> > 
> > * Rafael J. Wysocki <rjw@sisk.pl> wrote:
> > 
> > > On Tuesday 03 March 2009, Robert Richter wrote:
> > > > Fix upstream in tip/x86/urgent:
> > > > 
> > > > 780eef9492b16a1543a3b2ae9f9526a735fc9856
> > > 
> > > URL, please?
> > 
> > The fix is not yet in Linus's tree - the commit is below.
> 
> The fix is upstream now, included in .29-rc7.


Note You need to log in before you can comment on or make changes to this bug.