Bug 12390 - Notebook "pauses" when very idle with tickless kernel enabled
Summary: Notebook "pauses" when very idle with tickless kernel enabled
Status: CLOSED DUPLICATE of bug 12118
Alias: None
Product: ACPI
Classification: Unclassified
Component: Power-Processor (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: acpi_power-processor
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-01-09 02:08 UTC by James Ettle
Modified: 2009-01-16 11:21 UTC (History)
0 users

See Also:
Kernel Version: 2.6.24.4
Tree: Mainline
Regression: ---


Attachments

Description James Ettle 2009-01-09 02:08:24 UTC
Latest working kernel version: Unknown
Earliest failing kernel version: 2.6.24.4 (first kernel I used on this machine) 
Distribution: Fedora 8--10
Hardware Environment: x86-64, Clevo M720R notebook, Intel Core 2 Duo T8100 processor, X3100 graphics
Software Environment: x86-64 and i386

Problem Description:
My Intel Core 2 Duo T8100-based notebook seems to daydream: when left to idle (and I mean, really idle --- so unplug/disable all USB devices and network in order to quieten interrupts), and drop to a really low-power state, everything seems to stop bar the interrupt handler. So, the screen "pauses" (console or X: intel driver, X3100 hardware) and low-cpu-usage tasks stop. Hit the keyboard, touchpad, USB device, etc., and it comes back to life as if nothing's happened. No error messages, no crashes, no apparent corruption of anything.

Start the kernel with nohz=off, and this doesn't happen --- but then the processor is stuck in the C0 state. Nor does it happen if the machine is kept very busy when tickless is enabled.

Still happens with kernel 2.6.28 as far as I can see. Most often noticed during shutdown (although sometimes during startup when udev is starting) and I have to keep pressing the any key to get it to finish up and switch off.

Steps to reproduce:
1. Start notebook.
2. Quieten hardware, let it idle, and after a while (10-40s) the machine "pauses".
3. Use touchpad, keyboard, etc. and machine carries on apparently without any ill effect.
Comment 1 James Ettle 2009-01-09 07:57:46 UTC

*** This bug has been marked as a duplicate of bug 12118 ***

Note You need to log in before you can comment on or make changes to this bug.