Bug 12361 - xbacklight doesn't change the display brightness on ThinkPad X61s
Summary: xbacklight doesn't change the display brightness on ThinkPad X61s
Status: CLOSED DUPLICATE of bug 12401
Alias: None
Product: ACPI
Classification: Unclassified
Component: Power-Video (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: acpi_power-video
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-01-05 01:52 UTC by Tino Keitel
Modified: 2009-01-16 11:20 UTC (History)
5 users (show)

See Also:
Kernel Version: 2.6.28
Tree: Mainline
Regression: Yes


Attachments
acpidump output (283.77 KB, text/plain)
2009-01-05 02:54 UTC, Tino Keitel
Details

Description Tino Keitel 2009-01-05 01:52:34 UTC
Latest working kernel version: 2.6.27.8
Earliest failing kernel version: 2.6.28
Distribution: Debian Sid
Hardware Environment: ThinkPad X61s
Software Environment: Xorg 7.4
Problem Description: xbacklight doesn't change the display brightness

Steps to reproduce:

$ xbacklight
100.000000
$ xbacklight -set 10
$ xbacklight
6.666667
$

However, the actual brightness doesn't change.
Comment 1 Tino Keitel 2009-01-05 02:54:58 UTC
Created attachment 19653 [details]
acpidump output
Comment 2 Tino Keitel 2009-01-05 02:57:19 UTC
More information from the original bug report mail:

backlight information taken with 2.6.27.8:
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

dmesg:

acpi device:03: registered as cooling_device2
input: Video Bus as /class/input/input8
ACPI: Video Device [VID] (multi-head: yes  rom: no  post: no)
acpi device:08: registered as cooling_device3
input: Video Bus as /class/input/input9
ACPI: Video Device [VID1] (multi-head: yes  rom: no  post: no)

xrandr --prop:

Screen 0: minimum 320 x 200, current 1024 x 768, maximum 1024 x 1024
VGA disconnected (normal left inverted right x axis y axis)
LVDS connected 1024x768+0+0 (normal left inverted right x axis y axis) 246mm x 185mm
	EDID_DATA:
		00ffffffffffff0030ae004000000000
		000f010380191278eaed7591574f8b26
		21505421080001010101010101010101
		01010101010128150040410026301888
		3600f6b900000018ed10004041002630
		18883600f6b9000000180000000f0061
		43326143280f01004ca3584a000000fe
		004c544e313231584a2d4c30370a0000
	PANEL_FITTING: full
		supported: center       full_aspect  full        
	BACKLIGHT_CONTROL: kernel
		supported: native       legacy       combination  kernel      
	BACKLIGHT: 10 (0x0000000a) range:  (0,15)
   1024x768       50.0*+   60.0     40.0  
   800x600        60.3  
   640x480        60.0     59.9
Xorg log:

(II) intel(0): found backlight control method /sys/class/backlight/acpi_video1

sysfs:

/sys/class/backlight/acpi_video0/subsystem/acpi_video1/bl_power:0
/sys/class/backlight/acpi_video0/subsystem/acpi_video1/brightness:10
/sys/class/backlight/acpi_video0/subsystem/acpi_video1/actual_brightness:10
/sys/class/backlight/acpi_video0/subsystem/acpi_video1/max_brightness:15
/sys/class/backlight/acpi_video0/subsystem/acpi_video1/power/wakeup:
/sys/class/backlight/acpi_video0/bl_power:0
/sys/class/backlight/acpi_video0/brightness:9
/sys/class/backlight/acpi_video0/actual_brightness:12
/sys/class/backlight/acpi_video0/max_brightness:15
/sys/class/backlight/acpi_video0/power/wakeup:
/sys/class/backlight/acpi_video1/subsystem/acpi_video0/bl_power:0
/sys/class/backlight/acpi_video1/subsystem/acpi_video0/brightness:9
/sys/class/backlight/acpi_video1/subsystem/acpi_video0/actual_brightness:12
/sys/class/backlight/acpi_video1/subsystem/acpi_video0/max_brightness:15
/sys/class/backlight/acpi_video1/subsystem/acpi_video0/power/wakeup:
/sys/class/backlight/acpi_video1/bl_power:0
/sys/class/backlight/acpi_video1/brightness:10
/sys/class/backlight/acpi_video1/actual_brightness:10
/sys/class/backlight/acpi_video1/max_brightness:15
/sys/class/backlight/acpi_video1/power/wakeup:

backlight information taken with 2.6.28:
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

dmesg:

acpi device:03: registered as cooling_device2
input: Video Bus as /class/input/input7
ACPI: Video Device [VID] (multi-head: yes  rom: no  post: no)

xrandr --prop:

Screen 0: minimum 320 x 200, current 1024 x 768, maximum 1024 x 1024
VGA disconnected (normal left inverted right x axis y axis)
LVDS connected 1024x768+0+0 (normal left inverted right x axis y axis) 246mm x 185mm
	EDID_DATA:
		00ffffffffffff0030ae004000000000
		000f010380191278eaed7591574f8b26
		21505421080001010101010101010101
		01010101010128150040410026301888
		3600f6b900000018ed10004041002630
		18883600f6b9000000180000000f0061
		43326143280f01004ca3584a000000fe
		004c544e313231584a2d4c30370a0000
	PANEL_FITTING: full
		supported: center       full_aspect  full        
	BACKLIGHT_CONTROL: kernel
		supported: native       legacy       combination  kernel      
	BACKLIGHT: 5 (0x00000005) range:  (0,15)
   1024x768       50.0*+   60.0     40.0  
   800x600        60.3  
   640x480        60.0     59.9
Xorg log:

(II) intel(0): found backlight control method /sys/class/backlight/acpi_video0

sysfs:

/sys/class/backlight/acpi_video0/actual_brightness:5
/sys/class/backlight/acpi_video0/bl_power:0
/sys/class/backlight/acpi_video0/brightness:5
/sys/class/backlight/acpi_video0/max_brightness:15
/sys/class/backlight/acpi_video0/power/wakeup:
/sys/class/backlight/acpi_video0/subsystem/acpi_video0/bl_power:0
/sys/class/backlight/acpi_video0/subsystem/acpi_video0/brightness:5
/sys/class/backlight/acpi_video0/subsystem/acpi_video0/actual_brightness:5
/sys/class/backlight/acpi_video0/subsystem/acpi_video0/max_brightness:15
/sys/class/backlight/acpi_video0/subsystem/acpi_video0/power/wakeup:
Comment 3 Zhang Rui 2009-01-11 17:45:44 UTC

*** This bug has been marked as a duplicate of bug 12401 ***

Note You need to log in before you can comment on or make changes to this bug.