Bug 12359 - WARNING and other intel modesetting problems
WARNING and other intel modesetting problems
Status: RESOLVED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel)
All Linux
: P1 normal
Assigned To: drivers_video-dri-intel@kernel-bugs.osdl.org
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-04 09:07 UTC by Dennis Jansen
Modified: 2010-07-24 09:29 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.29-7d3b56ba37a95f1f370f50258ed3954c304c524b
Tree: Mainline
Regression: No


Attachments
dualhead dmesg (123.21 KB, text/plain)
2009-01-04 09:12 UTC, Dennis Jansen
Details
dualhead xorg.log (13.84 KB, text/plain)
2009-01-04 09:12 UTC, Dennis Jansen
Details
xorg.conf (2.94 KB, text/plain)
2009-01-04 10:20 UTC, Dennis Jansen
Details
dualhead xorg log w 2.5.99.2 (21.29 KB, text/plain)
2009-01-09 14:52 UTC, Dennis Jansen
Details
dualhead dmesg w. 2.5.99.2 (123.43 KB, text/plain)
2009-01-09 14:53 UTC, Dennis Jansen
Details

Description Dennis Jansen 2009-01-04 09:07:47 UTC
Distribution: Ubuntu 8.10
Hardware Environment: Acer Extensa 5220
Software Environment: Xorg 7.4~5ubuntu3
Problem Description:

Intel modesetting works fine on the console (as long as vesafb is not used).
[   51.675136] allocated 1280x1024 fb: 0x007df000, bo ffff88007f1fd600
[   51.681325] Console: switching to colour frame buffer device 160x50
[   51.742152] [drm] DAC-6: set mode 1280x1024 24
[   51.762350] [drm:i915_get_vblank_counter] *ERROR* trying to get vblank count for disabled pipe 1
[   51.802988] [drm] LVDS-8: set mode 1280x800 20
[   51.806349] fb0: inteldrmfb frame buffer device
[   51.806351] registered panic notifier
[   51.806356] [drm] Initialized i915 1.6.0 20080730 on minor 0

But I get a 
WARNING: at drivers/gpu/drm/drm_crtc.c:213 drm_mode_object_get+0x49/0xaf()

And I can't start X with it activated. I use intel xorg module v. 2.5.0. 

[  155.265134] Xorg:8838 map pfn expected mapping type uncached-minus for d0000000-e0000000, got write-combining

Fatal server error:
AddScreen/ScreenInit failed for driver 0

I will attach log files.
Comment 1 Dennis Jansen 2009-01-04 09:12:08 UTC
Created attachment 19643 [details]
dualhead dmesg

This seems related btw. http://www.gossamer-threads.com/lists/linux/kernel/917056
Comment 2 Dennis Jansen 2009-01-04 09:12:29 UTC
Created attachment 19644 [details]
dualhead xorg.log
Comment 3 Dennis Jansen 2009-01-04 09:57:14 UTC
Booting with nopat let me start X, but the screens were partly garbled. I could move the mouse, but when I tried to exit (Ctrl-Alt-F1 or Backspace), the display hung up completely filled with noise.
Comment 4 Dennis Jansen 2009-01-04 10:20:46 UTC
Created attachment 19645 [details]
xorg.conf

btw. intel module version 2.5.99.1 makes no difference. xorg.conf attached.
Comment 5 Yves-Alexis Perez 2009-01-04 10:34:55 UTC
Maybe try to build intel module with --enable-kms?
Comment 6 Dennis Jansen 2009-01-04 11:15:06 UTC
Oh. that might well be it. intel driver 2.5.99 doesn't compile with --enable-kms though... 2.5.0 doesn't have the option. I'll try 2.5.1.
Thanks!
Comment 7 Yves-Alexis Perez 2009-01-04 11:26:54 UTC
You first have to figure out how to build 2.5.99 with enable-kms (mainly, I needed to update x11proto-core-dev to 7.0.14.
Comment 8 Dennis Jansen 2009-01-05 01:28:21 UTC
I tried 2.5.1 with --enable-kms and it was worse than 2.5.99 without. My Ubuntu doesn't have that package version available(only 7.0.12). The compile error of intel 2.5.99 --enable-kms is:
drmmode_display.c:149: error: 'struct _xf86Crtc' has no member named 'transformPresent'
drmmode_display.c:170: error: too few arguments to function 'xf86CrtcRotate'
I'll try again sometime in a week.
Thanks!
Comment 9 Eric Anholt 2009-01-05 11:04:15 UTC
> And I can't start X with it activated. I use intel xorg module v. 2.5.0. 

        Choose this option if you want kernel modesetting enabled by default,
        and you have a new enough userspace to support this. Running old
        userspaces with this enabled will cause pain.

You can't run non-kms aware X with kms enabled.  This should be marked invalid.
Comment 10 Dennis Jansen 2009-01-05 14:27:15 UTC
Well at least the kernel warning on loading the i915 module is valid, right? And the other part is yet to be confirmed.
Comment 11 Dennis Jansen 2009-01-05 14:30:53 UTC
btw. intel v. 2.5.1 was compiled with --enable-kms and still didn't work.(see #8)
Comment 12 Yves-Alexis Perez 2009-01-05 14:41:09 UTC
I'm not really sure 2.5.1 even supports KMS?
Comment 13 Dennis Jansen 2009-01-05 14:51:35 UTC
2.5.1's got a configure option --enable-kms. I assumed it's there for a reason. But I haven't found any compatibility lists anywhere.
Comment 14 Eric Anholt 2009-01-05 15:18:28 UTC
If it doesn't build by default, it's probably not meant for real use.

(No, don't use old kms code, please)
Comment 15 Dennis Jansen 2009-01-05 23:51:46 UTC
If you are talking about the --enable-kms - it doesn't build by default even in 2.5.99(which doesn't build even with jaunty's xorg packages). So there's just no released "new" code for it yet?

As the new drivers don't build with any current ubuntu xorg (and jaunty's intel drivers don't work either), I won't be able to test them until ubuntu upgrades it xorg packages. So for now there's just the warning I guess.

Somehow the warning now comes along with several seconds of waiting (and blocking the modprobe util) until the resolutions are set.
Comment 16 Yves-Alexis Perez 2009-01-06 00:59:08 UTC
(In reply to comment #15)
> If you are talking about the --enable-kms - it doesn't build by default even in
> 2.5.99(which doesn't build even with jaunty's xorg packages). So there's just
> no released "new" code for it yet?

They *do* build. I had problem with build-deps (as I said, with x11proto-core for example), but I eventually managed to do that. I don't know jaunty packages, but basically you'll need a lot of .99.x -dev package.
Comment 17 Dennis Jansen 2009-01-06 04:11:33 UTC
Ah. Silly me. I forgot some packages: not only xserver-xorg but also x11proto-* xserver-xorg-dev. I will test it again now.
Comment 18 Dennis Jansen 2009-01-06 04:30:34 UTC
Okay, now I've tried 2.5.99, too. (Thanks, Yves-Alexis!) Didn't work either. It hung in the console with a blinking cursor (mirrored on both screens). I could Sysrq-REISU but not B. (It hung up completely during the emergency reset. The cursor even stopped blinking. ;) )

Maybe we can now start to find out where the problem lies?

Ah, great. Now I can't remove the NEEDINFO. Someone please set it back to NEW.
Comment 19 Jesse Barnes 2009-01-06 09:32:00 UTC
You'll probably want to use the git version of xf86-video-intel along with setting the "AccelMethod" option to "UXA" in your xorg.conf.  Eric's kernel tree has a few fixes as well, git://git.kernel.org/pub/scm/linux/kernel/git/anholt/drm-intel (drm-intel-next branch).
Comment 20 Dennis Jansen 2009-01-09 14:52:52 UTC
Created attachment 19735 [details]
dualhead xorg log w 2.5.99.2

I've tried again with the just-released 2.5.99.2. And I've gotten it to work for a while. I used UXA as you suggested. I could start xterm and switch back and forth between console and X. The external monitor has the wrong resolution and the display was corrupted. The notebooks internal monitor seemed fine. The background was pitch black. mplayer worked, I think with the x11 driver.

Then I tried starting konsole. Everything hung when I tried to "ls". I'll attach fresh xorg and dmesg logs:

FatalError re-entered, aborting 
Failure to wait for IRQ: Device or resource busy
and
[  683.442040] [drm:i915_wait_irq] *ERROR* EBUSY -- rec: 7 emitted: 8
[  686.442040] [drm:i915_wait_irq] *ERROR* EBUSY -- rec: 7 emitted: 9

I still couldn't start a single-head setup.
Comment 21 Dennis Jansen 2009-01-09 14:53:25 UTC
Created attachment 19736 [details]
dualhead dmesg w. 2.5.99.2
Comment 22 Gordon Jin 2009-09-18 02:57:20 UTC
Does this still exist in kernel 2.6.31 + xf86-video-intel 2.8.x? Lots of KMS fixes have been added in the past 8 months.
Comment 23 Dennis Jansen 2009-09-18 07:39:49 UTC
Yeah, well I currently have no dual-head setup. But the problems in here do not exist for me with my single head setup. On the other hand I have no console at all right now when I boot, only X - but that's another bug...
Comment 24 Chris Wilson 2010-07-24 09:29:38 UTC
Timeout, appear to be very old userspace bugs.

Note You need to log in before you can comment on or make changes to this bug.