Bug 12354 - Advisory: Debian's current initramdisk scripts break with an ext4 root
Summary: Advisory: Debian's current initramdisk scripts break with an ext4 root
Status: CLOSED CODE_FIX
Alias: None
Product: File System
Classification: Unclassified
Component: ext4 (show other bugs)
Hardware: All Linux
: P1 enhancement
Assignee: fs_ext4@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-01-03 23:02 UTC by Jim Bray
Modified: 2009-01-04 11:30 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.28
Tree: Mainline
Regression: ---


Attachments
Patch to klibc to allow it to properly probe ext4/ext4dev filesystems (5.50 KB, patch)
2009-01-04 11:16 UTC, Theodore Tso
Details | Diff

Description Jim Bray 2009-01-03 23:02:15 UTC
This is just a heads-up to hopefully save other people some time. I'm running 2.6.28 with debian/unstable, finally converted the root to ext4, and discovered that Debian with an initrd can't boot it because the initrd scripts apparently decide it is an ext3 filesystem with unsupported features. Not that they report this: instead you get an ENODEV message that had me convinced ext4 wasn't registering itself or some other such weirdness. Works fine if you use a "rootfstype=ext4" kernel boot parameter, or no initrd.
Comment 1 Jim Bray 2009-01-04 10:14:33 UTC
  I traced the problem thru the Debian initrd scripts to klibc/bin/fstype and have filed a Debian bug on it. If kernel-hackers are the ultimate upstream klibc source, please let me know and I'll refile it in other/klibc/kinit.

# /usr/lib/klibc/bin/fstype /dev/sda5 //a 100% made-from-scratch ext4 fs
FSTYPE=ext3
FSSIZE=12000649216
Comment 2 Theodore Tso 2009-01-04 11:14:08 UTC
I submitted a patch to klibc@zytor.com mailing list on Sat, 11 Oct 2008 10:54:44 -0400.  (Subject line: [PATCH] fstype: Fix ext4/ext4dev probing).

No one ever got back to me.  hpa?   Do you need me to resend?
Comment 3 Theodore Tso 2009-01-04 11:16:10 UTC
Created attachment 19648 [details]
Patch to klibc to allow it to properly probe ext4/ext4dev filesystems
Comment 4 H. Peter Anvin 2009-01-04 11:30:06 UTC
Applied, and a new klibc (1.5.15) has been pushed out.

Note You need to log in before you can comment on or make changes to this bug.