Bug 12339 - ne2000 doesn't set udev DRIVER attribute
ne2000 doesn't set udev DRIVER attribute
Status: RESOLVED OBSOLETE
Product: Drivers
Classification: Unclassified
Component: Network
All Linux
: P1 normal
Assigned To: drivers_network@kernel-bugs.osdl.org
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-31 16:44 UTC by Christopher Head
Modified: 2013-12-10 16:23 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.28
Tree: Mainline
Regression: No


Attachments

Description Christopher Head 2008-12-31 16:44:31 UTC
The ne2000 driver does not set the DRIVER attribute in udev. This causes persistent network device naming to ignore the device, thinking it to be a virtual device of some sort that ought not to be persistently named.

Relevant output:
# udevadm info -a -p /sys/class/net/eth0

Udevinfo starts with the device specified by the devpath and then
walks up the chain of parent devices. It prints for every device
found, all possible attributes in the udev rules key format.
A rule to match, can be composed by the attributes of the device
and the attributes from one single parent device.

  looking at device '/devices/virtual/net/eth0':
    KERNEL=="eth0"
    SUBSYSTEM=="net"
    DRIVER==""
    ATTR{addr_len}=="6"
    ATTR{iflink}=="2"
    ATTR{ifindex}=="2"
    ATTR{features}=="0x0"
    ATTR{type}=="1"
    ATTR{link_mode}=="0"
    ATTR{address}=="00:80:c8:2c:71:a2"
    ATTR{broadcast}=="ff:ff:ff:ff:ff:ff"
    ATTR{carrier}=="1"
    ATTR{dormant}=="0"
    ATTR{operstate}=="unknown"
    ATTR{mtu}=="1500"
    ATTR{flags}=="0x1003"
    ATTR{tx_queue_len}=="1000"

  looking at parent device '/devices/virtual/net':
    KERNELS=="net"
    SUBSYSTEMS==""
    DRIVERS==""

  looking at parent device '/devices/virtual':
    KERNELS=="virtual"
    SUBSYSTEMS==""
    DRIVERS==""


Downstream <http://bugs.gentoo.org/show_bug.cgi?id=252449>, Daniel Drake suggests that maybe "this is because the driver does not call SET_NETDEV_DEV()".
Comment 1 Anonymous Emailer 2009-01-05 14:55:06 UTC
Reply-To: akpm@linux-foundation.org


(switched to email.  Please respond via emailed reply-to-all, not via the
bugzilla web interface).

On Wed, 31 Dec 2008 16:44:31 -0800 (PST)
bugme-daemon@bugzilla.kernel.org wrote:

> http://bugzilla.kernel.org/show_bug.cgi?id=12339
> 
>            Summary: ne2000 doesn't set udev DRIVER attribute
>            Product: Networking
>            Version: 2.5
>      KernelVersion: 2.6.28
>           Platform: All
>         OS/Version: Linux
>               Tree: Mainline
>             Status: NEW
>           Severity: normal
>           Priority: P1
>          Component: Other
>         AssignedTo: acme@ghostprotocols.net
>         ReportedBy: chead@telus.net
> 
> 
> The ne2000 driver does not set the DRIVER attribute in udev. This causes
> persistent network device naming to ignore the device, thinking it to be a
> virtual device of some sort that ought not to be persistently named.
> 
> Relevant output:
> # udevadm info -a -p /sys/class/net/eth0
> 
> Udevinfo starts with the device specified by the devpath and then
> walks up the chain of parent devices. It prints for every device
> found, all possible attributes in the udev rules key format.
> A rule to match, can be composed by the attributes of the device
> and the attributes from one single parent device.
> 
>   looking at device '/devices/virtual/net/eth0':
>     KERNEL=="eth0"
>     SUBSYSTEM=="net"
>     DRIVER==""
>     ATTR{addr_len}=="6"
>     ATTR{iflink}=="2"
>     ATTR{ifindex}=="2"
>     ATTR{features}=="0x0"
>     ATTR{type}=="1"
>     ATTR{link_mode}=="0"
>     ATTR{address}=="00:80:c8:2c:71:a2"
>     ATTR{broadcast}=="ff:ff:ff:ff:ff:ff"
>     ATTR{carrier}=="1"
>     ATTR{dormant}=="0"
>     ATTR{operstate}=="unknown"
>     ATTR{mtu}=="1500"
>     ATTR{flags}=="0x1003"
>     ATTR{tx_queue_len}=="1000"
> 
>   looking at parent device '/devices/virtual/net':
>     KERNELS=="net"
>     SUBSYSTEMS==""
>     DRIVERS==""
> 
>   looking at parent device '/devices/virtual':
>     KERNELS=="virtual"
>     SUBSYSTEMS==""
>     DRIVERS==""
> 
> 
> Downstream <http://bugs.gentoo.org/show_bug.cgi?id=252449>, Daniel Drake
> suggests that maybe "this is because the driver does not call
> SET_NETDEV_DEV()".
> 


Comment 2 Alan 2009-03-26 16:13:01 UTC
This is because it is an ISA device driver so really had no device to use. Nowdays its using platform device so this might be updatable. I'd argue this is a udev bug at least half of it anyway
Comment 3 Tom Wijsman 2012-10-31 01:06:29 UTC
Is this bug still present? Has someone checked up with udev on this?
Comment 4 Alan 2012-10-31 10:22:02 UTC
Yes it is still present, although the fix is my patch queue as it happens now I'm tidying up the sillier bugs

Note You need to log in before you can comment on or make changes to this bug.