Bug 12337 - ~100 extra wakeups reported by powertop
~100 extra wakeups reported by powertop
Status: CLOSED INVALID
Product: Power Management
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: power-management_other
:
Depends on:
Blocks: 11808
  Show dependency treegraph
 
Reported: 2008-12-31 12:25 UTC by Alberto Gonzalez
Modified: 2009-03-14 14:56 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.28
Tree: Mainline
Regression: Yes


Attachments
dmesg log from 2.6.27.10 (19.72 KB, application/octet-stream)
2008-12-31 12:26 UTC, Alberto Gonzalez
Details
dmesg log from 2.6.28 (21.14 KB, application/octet-stream)
2008-12-31 12:26 UTC, Alberto Gonzalez
Details
dmesg log from 2.6.28 after resume from hibernation (24.55 KB, application/octet-stream)
2008-12-31 12:27 UTC, Alberto Gonzalez
Details

Description Alberto Gonzalez 2008-12-31 12:25:43 UTC
Latest working kernel version: 2.6.27.10
Earliest failing kernel version: 2.6.28
Distribution: Arch Linux
Hardware Environment: x86
Software Environment: x86
Problem Description:

With 2.6.27.10 I get about 10 wakeups per second as reported by powertop (on an idle system), but after upgrading to 2.6.28 I get about 100 extra wakeups due to:

<interrupt> : uhci_hcd:usb1, i915@pci:0000:00:02.0

The interesting thing is that if I suspend (to disk or to RAM) the system and then resume it, those extra wakeups go away.

This is an old Pentium 4 desktop with i845GL chipset. The kernels used are the
stock ones from Arch Linux (pretty vanilla kernels, and I don't even know how
to compile my own anyway). I'll attach dmesg from 2.6.27.10, 2.6.28 and 2.6.28 after resume from hibernation.

Thanks.
Comment 1 Alberto Gonzalez 2008-12-31 12:26:24 UTC
Created attachment 19575 [details]
dmesg log from 2.6.27.10
Comment 2 Alberto Gonzalez 2008-12-31 12:26:50 UTC
Created attachment 19576 [details]
dmesg log from 2.6.28
Comment 3 Alberto Gonzalez 2008-12-31 12:27:11 UTC
Created attachment 19577 [details]
dmesg log from 2.6.28 after resume from hibernation
Comment 4 Alberto Gonzalez 2009-01-01 23:30:55 UTC
I've found that switching to console and back to X fixes the problem too. Same if I start the system in runlevel 2 and then start X manually.

So it looks like a simple timing problem, as if X starts before it should (?).
Comment 5 Eric Anholt 2009-01-02 14:17:09 UTC
this is probably an issue with getting vblank interrupts turned off because we lose track of the state during X startup.  jbarnes had been looking into an issue like this before.
Comment 6 Rafael J. Wysocki 2009-02-04 15:53:48 UTC
On Wednesday 04 February 2009, Alberto Gonzalez wrote:
> --- On Wed, 2/4/09, Rafael J. Wysocki <rjw@sisk.pl> wrote:
> 
> > The following bug entry is on the current list of known
> > regressions
> > introduced between 2.6.27 and 2.6.28.  Please verify if it
> > still should
> > be listed and let me know (either way).
> > 
> > 
> > Bug-Entry	:
> > http://bugzilla.kernel.org/show_bug.cgi?id=12337
> > Subject		: ~100 extra wakeups reported by powertop
> > Submitter	: Alberto Gonzalez <luis6674@yahoo.com>
> > Date		: 2008-12-31 12:25 (36 days old)
> 
> Yes, still present in latest stable 2.6.28.3

Comment 7 Alberto Gonzalez 2009-02-12 12:21:08 UTC
I got a new computer, a Dell Studio desktop based on an Intel G45 chipset (using the integrated graphics), and I have the exact same problem. After booting I have around 75 wakeups per second from the same source, and switching to console and back to X also fixes the problem.

If it happened on my 5+ year old Pentium 4 (on a 32 bit kernel) and it happens on a new Core 2 duo (on a 64 bit kernel), it's unlikely I'm the only one seeing this, so hopefully someone with better knowledge can reproduce the problem and help better to fix it.
Comment 8 Henrique de Moraes Holschuh 2009-02-24 05:54:09 UTC
HOW TO REPRODUCE:

(taken from a post by Alberto Gonzalez to LKML):

---8<---

Since Arch Linux is not popular among kernel developers I just tested Fedora 10 Live-CD (KDE) and I can reproduce the exact same problem, even if Fedora 10 has kernel 2.6.27 and for me the problem appeared in .28 (but I guess Fedora adds many patches, so probably the "guilty" commit was backported to 2.6.27.5-117-FC10-i686).

Steps:
- Boot into Fedora 10 Live CD (obviously, into the default graphical mode)                                                                 
- Install Powertop (yum install powertop) and run
- I get about 60 wakeups per second from i915@pci.... leaving the system idle
- Switch to console and back to X. The wakeups are gone.
Comment 9 Henrique de Moraes Holschuh 2009-02-24 09:47:47 UTC
Also tracked at:

http://bugs.freedesktop.org/show_bug.cgi?id=20296
Comment 10 Rafael J. Wysocki 2009-02-25 14:46:40 UTC
On Tuesday 24 February 2009, Alberto Gonzalez wrote:
> --- On Mon, 2/23/09, Rafael J. Wysocki <rjw@sisk.pl> wrote:
> 
> > The following bug entry is on the current list of known
> > regressions
> > introduced between 2.6.27 and 2.6.28.  Please verify if it
> > still should
> > be listed and let me know (either way).
> > 
> > 
> > Bug-Entry	:
> > http://bugzilla.kernel.org/show_bug.cgi?id=12337
> > Subject		: ~100 extra wakeups reported by powertop
> > Submitter	: Alberto Gonzalez <luis6674@yahoo.com>
> > Date		: 2008-12-31 12:25 (55 days old)
> 
> Still present, yes.

Comment 11 Rafael J. Wysocki 2009-03-14 14:55:43 UTC
On Tuesday 03 March 2009, Alberto Gonzalez wrote:
> --- On Tue, 3/3/09, Rafael J. Wysocki wrote:
> 
> > The following bug entry is on the current list of known
> > regressions
> > introduced between 2.6.27 and 2.6.28.  Please verify if it
> > still should
> > be listed and let me know (either way).
> > 
> > 
> > Bug-Entry	:
> > http://bugzilla.kernel.org/show_bug.cgi?id=12337
> > Subject		: ~100 extra wakeups reported by powertop
> > Submitter	: Alberto Gonzalez <luis6674@yahoo.com>
> > Date		: 2008-12-31 12:25 (63 days old)
> 
> J. Barnes said this is a bug in the intel driver, even if it appeared after a kernel upgrade.
> 
> If you prefer to close it for now, fine with me. If you prefer to wait until it's confirmed, fine too. Whatever is ore convenient for your tracking.
> 
> I'll update the report in any case when I know more.


Note You need to log in before you can comment on or make changes to this bug.