Bug 12336 - hda-intel: no sound on headphone jack output (Dell Latitude E6400)
Summary: hda-intel: no sound on headphone jack output (Dell Latitude E6400)
Alias: None
Product: Drivers
Classification: Unclassified
Component: Sound(ALSA) (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Jaroslav Kysela
Depends on:
Reported: 2008-12-31 04:10 UTC by Adam Piątyszek
Modified: 2012-05-30 11:29 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.28
Regression: No
Bisected commit-id:

alsa-info.sh output for 2.6.28 kernel with non-working headphone jack (23.89 KB, text/plain)
2008-12-31 04:12 UTC, Adam Piątyszek
alsa-info.sh output for git kernel with commit 5d5d5f43f1b835 reverted (18.71 KB, text/plain)
2009-01-01 23:57 UTC, Adam Piątyszek
alsa-info.sh output for kernel with working headphone jack (18.04 KB, text/plain)
2009-01-21 07:12 UTC, David Rosenstrauch
alsa-info.sh output for kernel with non-working headphone jack (19.44 KB, text/plain)
2009-01-21 07:12 UTC, David Rosenstrauch

Description Adam Piątyszek 2008-12-31 04:10:50 UTC
Latest working kernel version:
- with a few gentoo patches listed here: 

Earliest failing kernel version:
- ? (have not tried to bisect the problem yet)

- Gentoo Linux

Hardware Environment:
- Dell Latitude E6400 (Centrino 2 platform with Core2Duo P8600 and Intel GM45 integrated graphics)
- HDA-Intel sound card with codec: IDT 92HD71B7X

Software Environment:
  - gentoo-sources-2.6.28
  - alsa-lib-1.0.17a
  - alsa-headers-1.0.17
  - alsa-utils-1.0.17

Problem Description:

There is no sound on the headphone jack output. However, when I plug in the headphone jack, the laptop speakers are switched off.
I tried to load snd-hda-intel driver without any model setting and with model=ref, model=dell-m4-1, model=dell-m4-2 and  model=dell-m4-4. None of them solves the described problem.

BTW, with model=ref and model=dell-m4-2, additional mixer switches (playback) are available as compared to other model settings and to previous (working) kernel without any specific model given, eg. IEC958, IEC958 Default PCM, IEC958 Playback Source, IEC958 Playback Source 1.

The output of alsa-info.sh script run on 2.6.28 kernel is attached.

Besides, I never managed to record anything with the digital microphone, which is integrated with this laptop. I tried a few times with stable kernels 2.6.27.x (from Gentoo). But this is unrelated to the headphone output regression.

Steps to reproduce:
Comment 1 Adam Piątyszek 2008-12-31 04:12:14 UTC
Created attachment 19573 [details]
alsa-info.sh output for 2.6.28 kernel with non-working headphone jack
Comment 2 Takashi Iwai 2009-01-01 01:54:51 UTC
I guess the model=ref won't work for your machine because it doesn't set GPIO used for external amplifier switch.

Anyway, please run alsa-info with the old working kernel to compare.
Comment 3 Adam Piątyszek 2009-01-01 23:56:02 UTC
It seems that I was wrong saying that was working properly. Headphones do not work with this vanilla kernel built from git. It seems that one of the patches from Gentoo results in a working headphone jack. This patch basically reverts the following change: 5d5d5f43f1b835c375de9bd270cce030d16e2871

Now I tried the git official kernel release v2.6.27.10 with reverted patch 5d5d5f43f1b835... and the headphone jack works with "model=ref". Please find the attached alsa-info.sh output for this particular kernel build.

So, it seems that this problem is not a regression between 2.6.27 and 2.6.28, but this laptop model is not yet fully supported.

Hope this helps!
Comment 4 Adam Piątyszek 2009-01-01 23:57:27 UTC
Created attachment 19602 [details]
alsa-info.sh output for git kernel with commit 5d5d5f43f1b835 reverted
Comment 5 Takashi Iwai 2009-01-06 23:11:21 UTC
The commit 5d5d5f43f1b835c375de9bd270cce030d16e2871 must be irrelevant.  It's for AD1986A codec.

Please double-check.

For 2.6.28 kernel, don't pass model=ref option.  Use the same as before, i.e. no model option (and reboot to restore the BIOS status after removing model=ref from modprobe.conf or such).  Then run alsa-info.sh --no-upload and attach the file again.
Comment 6 Adam Piątyszek 2009-01-07 04:12:54 UTC
You are right. I have just once again tested the vanilla 2.6.28 kernel without passing any "model" option and after rebooting the system headphone jack output works as expected. I should have checked this more careful before spamming bugzilla with a new bug report.

I am very sorry for making this noise!

Anyway, thanks for your help Takashi.
Comment 7 Adam Piątyszek 2009-01-10 20:42:10 UTC
It seems that this sound codec in Dell Latitude E6400/E6500 laptops is not fully supported by the latest stable kernel ALSA drivers. Here is a similar bug report I found on ALSA bugtrack:

I am thus reopening this bug report until the issue of headphone output and digital microphone is not solved.
Comment 8 Takashi Iwai 2009-01-13 03:57:53 UTC
But you mention in comment #6 that the headphone is working on your machine?

For the microphone, please create another bug report.  It's a totally different issue.
Comment 9 David Rosenstrauch 2009-01-20 04:29:10 UTC
I'm seeing this problem as well on Arch Linux after upgrading from kernel to 2.6.28.  My laptop (a Dell Precision M4400), which has the IDT 92HD71B7X codec and uses the snd-hda-intel module, no longer produces any audio output - either through the speakers or the headphones - after I upgrade the kernel.  Loading the module with no model parameter, as well as with various model parameters set (e.g., dell-m4-1, etc.) doesn't seem to fix the problem.
Comment 10 Takashi Iwai 2009-01-21 04:00:42 UTC
Please attach alsa-info.sh --no-upload option output.  Otherwise I can't analyze.
Comment 11 David Rosenstrauch 2009-01-21 04:15:40 UTC
???  Where is that script?  It doesn't appear to be part of either the alsa-lib or alsa-utils packages on my distro.
Comment 12 Takashi Iwai 2009-01-21 04:18:13 UTC
Comment 13 David Rosenstrauch 2009-01-21 07:12:34 UTC
Created attachment 19925 [details]
alsa-info.sh output for kernel with working headphone jack
Comment 14 David Rosenstrauch 2009-01-21 07:12:54 UTC
Created attachment 19926 [details]
alsa-info.sh output for kernel with non-working headphone jack
Comment 15 David Rosenstrauch 2009-01-21 07:13:50 UTC
OK, I've upgraded the alsa-info output from both the working and the non-working kernels.
Comment 16 erich mounce 2009-02-03 18:04:15 UTC
Same problem with ASUS G50V laptop using kernel

Comment 17 sveina 2009-08-27 21:02:11 UTC
I have this problem on a macbook pro 4.1, on the latest git kernel.

I'm attempting to bisect it to find out what caused it.
Comment 18 Alan 2012-05-30 11:29:23 UTC
Closing obsolete bug

Note You need to log in before you can comment on or make changes to this bug.