Bug 12317 - [TRIVIAL] MTRR cleanup WARN message (arch/x86/kernel/cpu/mtrr/generic.c:404)
[TRIVIAL] MTRR cleanup WARN message (arch/x86/kernel/cpu/mtrr/generic.c:404)
Status: CLOSED CODE_FIX
Product: Memory Management
Classification: Unclassified
Component: MTTR
All Linux
: P1 normal
Assigned To: Alan
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-28 09:19 UTC by Eugene Grygoriev
Modified: 2012-05-24 13:38 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.32
Tree: Mainline
Regression: No


Attachments
dmesg (44.10 KB, text/plain)
2008-12-28 09:20 UTC, Eugene Grygoriev
Details

Description Eugene Grygoriev 2008-12-28 09:19:49 UTC
Latest working kernel version: 2.6.27
Distribution: debian
Hardware Environment: MSI laptop (M673)
Software Environment: 32-bit kernel and userspace
Problem Description:

I've just built this kernel and got followed warning:

[    0.000000] ------------[ cut here ]------------
[    0.000000] WARNING: at arch/x86/kernel/cpu/mtrr/generic.c:404 generic_get_mtrr+0xea/0x120()
[    0.000000] mtrr: your BIOS has set up an incorrect mask, fixing it up.
[    0.000000] Modules linked in:
[    0.000000] Pid: 0, comm: swapper Not tainted 2.6.28 #1
[    0.000000] Call Trace:
[    0.000000]  [<c012a87f>] warn_slowpath+0x6f/0x90
[    0.000000]  [<c0373031>] fn_hash_delete+0x91/0x260
[    0.000000]  [<c0258724>] number+0x2b4/0x2c0
[    0.000000]  [<c0259353>] vsnprintf+0x393/0x670
[    0.000000]  [<c0143fd1>] up+0x11/0x40
[    0.000000]  [<c012b079>] release_console_sem+0x189/0x1d0
[    0.000000]  [<c01109da>] generic_get_mtrr+0xea/0x120
[    0.000000]  [<c04d98cf>] mtrr_trim_uncached_memory+0x7d/0x374
[    0.000000]  [<c03a2c6a>] printk+0x17/0x1b
[    0.000000]  [<c011ddbc>] pat_init+0x7c/0xa0
[    0.000000]  [<c0110eac>] post_set+0x1c/0x50
[    0.000000]  [<c03a2c6a>] printk+0x17/0x1b
[    0.000000]  [<c04d5d22>] e820_end_pfn+0xb5/0xd3
[    0.000000]  [<c04d41de>] setup_arch+0x516/0x808
[    0.000000]  [<c04d6e97>] reserve_early_overlap_ok+0x3f/0x47
[    0.000000]  [<c04cd5dc>] start_kernel+0x58/0x334
[    0.000000] ---[ end trace 4eaa2a86a8e2da22 ]---


This warning message was introduced by followed commit (emails cc-ed):
commit 16dc552f35bc0ec6fec8ef83f8032eee352d17f5
Author: Yinghai Lu <yhlu.kernel@gmail.com>
Date:   Fri Sep 19 11:45:04 2008 -0700

    x86: use WARN_ONCE in workaround for mtrr mask

    so could help catch attention about bug in bios about mtrr mask setting.

    WARN_ONCE got into mainline already, lets use it.

    Signed-off-by: Yinghai Lu <yhlu.kernel@gmail.com>
    Signed-off-by: Ingo Molnar <mingo@elte.hu>

2.6.27 shows only printk message about this. Since previous kernels (<=2.6.25) even don't warns about this, is it so important to warn so loud about this and mark kernel as tainted? Should I do something? (Laptop is old enough so please don't ask me to contact MSI for fixed BIOS). all kernels since 2.6.23 works without any problems here.
Comment 1 Eugene Grygoriev 2008-12-28 09:20:35 UTC
Created attachment 19509 [details]
dmesg
Comment 2 Chris Ruffin 2011-01-03 03:12:59 UTC
fixed in 942fa3b6

Note You need to log in before you can comment on or make changes to this bug.