Bug 12255 - Audigy2ZS with emu10k1 broken since 2.6.27.9 & 2.6.28-rc4
Summary: Audigy2ZS with emu10k1 broken since 2.6.27.9 & 2.6.28-rc4
Status: CLOSED INVALID
Alias: None
Product: Drivers
Classification: Unclassified
Component: Sound(ALSA) (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Takashi Iwai
URL:
Keywords:
Depends on:
Blocks: 11808
  Show dependency tree
 
Reported: 2008-12-19 13:02 UTC by Gabe
Modified: 2008-12-20 03:44 UTC (History)
1 user (show)

See Also:
Kernel Version: Since 2.6.27.9 and 2.6.28-rc4
Tree: Mainline
Regression: Yes


Attachments

Description Gabe 2008-12-19 13:02:44 UTC
Latest working kernel version: 2.6.27.8
Earliest failing kernel version: 2.6.28-rc4 or 2.6.27.9

Distribution: Arch Linux

Hardware Environment: x86_64, Q6600, 4GB RAM, 8800GT (tested without binary nvidia mod), Audigy2ZS

Software Environment: gcc-4.3.2, alsa software >=1.0.18

Problem Description: Ever since the introduction of 
"ALSA: emu10k1 - Add more invert_shared_spdif flag to Audigy models"
my sound has ceased to output, my hardware is recognized just like it was in kernels before the issue, everything is the same except that sound doesn't work.

Steps to reproduce: ALSA with emu10k1 module and soundcard, kernels 2.6.27.9+ and 2.6.28-rc4+
Comment 1 Takashi Iwai 2008-12-20 00:35:26 UTC
It have worked in a wrong way.  Now it's corrected.

The patch fixes the inverted implementation of "Audigy Analog/Digital" switch.  It must be OFF for analog-outputs while it was ON before the fix patch.

Note You need to log in before you can comment on or make changes to this bug.