Bug 12226 - ath5k sometimes hardlocks machine
Summary: ath5k sometimes hardlocks machine
Status: CLOSED DUPLICATE of bug 12647
Alias: None
Product: Drivers
Classification: Unclassified
Component: network-wireless (show other bugs)
Hardware: All Linux
: P1 high
Assignee: Bob Copeland
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-12-14 13:12 UTC by Rich Ercolani
Modified: 2009-02-15 00:46 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.27.9
Tree: Mainline
Regression: ---


Attachments

Description Rich Ercolani 2008-12-14 13:12:28 UTC
Latest working kernel version: N/A
Earliest failing kernel version: 2.6.27.8
Distribution: Ubuntu 8.10 amd64
Hardware Environment: ThinkPad T61p w/AR5212 miniPCIe
Software Environment: Ubuntu 8.10 AMD64, w/compat-wireless snapshot from December 2nd
Problem Description:
When loaded, the ath5k driver will sometimes produce stutters in my userland performance - I'll be playing music or something else using sound or video, and it'll stutter briefly.

I've tested this with no X running and across multiple players, and this is reproducibly only true when the ath5k driver is loaded.

I mention this because it sometimes locks my machine up completely - whatever sound was playing on the speaker repeats in an endless stutter, no input devices respond (not even SysRq). Again, only reproducible with ath5k loaded.

Steps to reproduce:
1) Load ath5k driver
2) Leave loaded and connected to a network or otherwise for awhile
3) Watch it stutter occasionally
4) Watch a hardlock occur

I've checked, and for obvious reasons, I get no messages in /var/log/{syslog,messages} from this. My laptop lacks a serial or parallel port - is there some other way I can debug this?
Comment 1 Bob Copeland 2008-12-31 06:53:19 UTC
Not sure if it'll help but you can try turning on ATH5K_DEBUG and setting up a netconsole on a wired ethernet port.  Does sysrq-t work while it first starts stuttering?  Capturing a few traces at that time could be informative.  Can you also lock it up when not playing music?  Also, please post your /proc/interrupts after it's been running some time.
Comment 2 Rich Ercolani 2008-12-31 20:31:03 UTC
Sure. I'll figure out how to set up a netconsole.

It's worth noting that this only occurs on WPA networks, as far as I can tell - it's run for hours on WEP networks, but after awhile on a WPA network, it fails dramatically.

Yes, it also locks up when not playing music, that only happened once or twice by coincidence, and was interesting as a state indicator.
Comment 3 Rich Ercolani 2008-12-31 20:31:40 UTC
Additionally, when it first starts stuttering, the system is utterly unresponsive to SysRq input.
Comment 4 Antoine Pairet 2009-01-01 01:34:58 UTC
(In reply to comment #2)
> Sure. I'll figure out how to set up a netconsole.
> 
> It's worth noting that this only occurs on WPA networks, as far as I can tell
> -
> it's run for hours on WEP networks, but after awhile on a WPA network, it
> fails
> dramatically.
> 
> Yes, it also locks up when not playing music, that only happened once or
> twice
> by coincidence, and was interesting as a state indicator.

I confirm this behavior. No problem with WEP, With WPA computer locks and become unusable. I also use Ubuntu 8.10. 

05:00.0 Ethernet controller: Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter (rev 01)
Comment 5 Bob Copeland 2009-01-01 15:02:07 UTC
So in both cases this is compat-wireless?  Can you try with the nohwcrypt parameter?  (modprobe ath5k nohwcrypt=1)
Comment 6 Rich Ercolani 2009-01-01 15:49:01 UTC
I will try it again shortly when I regain access to a WPA network (I'm currently on vacation), but if memory serves I tried this parameter to no effect.
Comment 7 Antoine Pairet 2009-01-02 01:25:06 UTC
Yes, I also use compat-wireless. I never used the option nohwcrypt and do not have access to WPA wireless for the moment. I will give it a try when going back to university in February.

regards,
Comment 8 Bob Copeland 2009-02-10 04:28:41 UTC
Ok it is clear that something is going on - I have seen lockups too under heavy load, no oops, nmi_watchdog doesn't work.  Since there is a newer bug with more/different info, I'm going to go ahead and close this one so we can put all the info in one place.
Comment 9 Bob Copeland 2009-02-10 04:29:30 UTC

*** This bug has been marked as a duplicate of bug 12647 ***

Note You need to log in before you can comment on or make changes to this bug.