Bug 12220 - "Kernel reboots if Powersupply of the Laptop is connected or disconnected v2"
"Kernel reboots if Powersupply of the Laptop is connected or disconnected v2"
Status: RESOLVED OBSOLETE
Product: Other
Classification: Unclassified
Component: Other
All Linux
: P1 high
Assigned To: other_other
:
: 11711 (view as bug list)
Depends on:
Blocks: 11711 56331
  Show dependency treegraph
 
Reported: 2008-12-14 07:01 UTC by Thomas
Modified: 2013-04-09 06:23 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.28_rc8
Tree: Mainline
Regression: No


Attachments
Minimal Kernelconfig with everything disabeld - Cashes also (5.61 KB, text/plain)
2008-12-14 07:03 UTC, Thomas
Details
Acpi Dump 2.6.28_rc8 (135.09 KB, text/plain)
2008-12-14 07:03 UTC, Thomas
Details
Dmesg of 2.6.28-rc8 (45.72 KB, text/plain)
2008-12-14 07:04 UTC, Thomas
Details
lspci of 2.6.28-rc8 (1.82 KB, text/plain)
2008-12-14 07:04 UTC, Thomas
Details
lsusb of 2.6.28-rc8 (409 bytes, text/plain)
2008-12-14 07:04 UTC, Thomas
Details
Systemhardware (1.15 KB, text/plain)
2008-12-14 07:05 UTC, Thomas
Details
Kernel Config for my 2.6.28_rc8 (46.59 KB, application/octet-stream)
2008-12-14 07:06 UTC, Thomas
Details
Bios Settings (368 bytes, text/plain)
2008-12-14 07:18 UTC, Thomas
Details
All Data whitch I could collect from the Suse Rescue CD (470.00 KB, application/x-tar)
2008-12-15 15:36 UTC, Thomas
Details

Description Thomas 2008-12-14 07:01:00 UTC
This Bug is a enhancement to bug nr: 11711
I opend this second Bugreport to make it more easy to read the hole stuff.
I compressed the answers of bug 11711 to this overview.
Latest working kernel version: ?
Earliest failing kernel version: ?
Distribution: Gentoo Linux 2008.1 / vanilla-kernel umasked
Hardware Environment: Laptop details later
Software Environment: none at this Point nothing other loaded
Problem Description: System Crashes if PowerSupply is plugged or unplugged
Itś not a duplicate of bug: #11658.
Steps to reproduce: Unplug Power Cord

Some information:

- The Crash is done as a reboot, you have no chance to get information form Scrren. (Like a Reset). You can't find anything in the var/log/messages file.

- booting with kernel param init=/bin/bash and playing with the cord --> crash

This Problem doesn't exist in Bios, Windows or Dos. Even if i plug/unplug
power supply at the beginning of the Kernel, it doesn't matter. The bug is
located shortly before the SATA Drivers. The SATA Driver it self is not the
Problem, because I used the old SATA Driver and had the same thing.

- Setting of CONFIG_X86_RESERVE_LOW_64K=y  doesn't help.

- System crashes also without acpi video drivers

If I try to boot with acpi=off apm=off usb=off
System hangs at io scheduler cfq registered (default) Don't know why.

New Questions:
==============
Is it possible to disable the kernel free process? because befor the free I can
unplug the power supply, after the free system crashes ?

Something I recognized.

If I use a Suse 11.0 Disk with rescue mode an boot this. The System dosn't crash If I unplug the power cord. The Disk has a 2.6.25 pre kernel!

Now I thought I use my gentoo and install 2.6.25. I unplugged and System crashed. Do you have any idea where the differece could be. PS. 2.6.25 would not work because I have a Mavell chipset, but only the thought, that the system could stay alive with this Kernel is interesting. Could It be that Suse is applying a microcode update or something ?? Or a DST file ?
Comment 1 Thomas 2008-12-14 07:03:24 UTC
Created attachment 19290 [details]
Minimal Kernelconfig with everything disabeld - Cashes also
Comment 2 Thomas 2008-12-14 07:03:51 UTC
Created attachment 19291 [details]
Acpi Dump 2.6.28_rc8
Comment 3 Thomas 2008-12-14 07:04:14 UTC
Created attachment 19292 [details]
Dmesg of 2.6.28-rc8
Comment 4 Thomas 2008-12-14 07:04:37 UTC
Created attachment 19293 [details]
lspci of 2.6.28-rc8
Comment 5 Thomas 2008-12-14 07:04:56 UTC
Created attachment 19294 [details]
lsusb of 2.6.28-rc8
Comment 6 Thomas 2008-12-14 07:05:17 UTC
Created attachment 19295 [details]
Systemhardware
Comment 7 Thomas 2008-12-14 07:06:39 UTC
Created attachment 19296 [details]
Kernel Config for my 2.6.28_rc8
Comment 8 Thomas 2008-12-14 07:18:00 UTC
Created attachment 19297 [details]
Bios Settings
Comment 9 Zhang Rui 2008-12-14 17:32:36 UTC
*** Bug 11711 has been marked as a duplicate of this bug. ***
Comment 10 Thomas 2008-12-15 15:36:37 UTC
Created attachment 19319 [details]
All Data whitch I could collect from the Suse Rescue CD

I couldn't do a acpidump because this tool is not included in SuSEś rescue mode.

Note You need to log in before you can comment on or make changes to this bug.