Bug 12213 - ieee1394, sbp2: login timeout with Sony PCGA-CRWD1 and PL-3507 based CD-RW
ieee1394, sbp2: login timeout with Sony PCGA-CRWD1 and PL-3507 based CD-RW
Status: CLOSED DUPLICATE of bug 12572
Product: Drivers
Classification: Unclassified
Component: IEEE1394
All Linux
: P1 normal
Assigned To: Stefan Richter
:
Depends on:
Blocks: 10046
  Show dependency treegraph
 
Reported: 2008-12-13 02:58 UTC by Stefan Richter
Modified: 2009-03-23 11:26 UTC (History)
0 users

See Also:
Kernel Version: all or recent
Tree: Mainline
Regression: Yes


Attachments

Description Stefan Richter 2008-12-13 02:58:12 UTC
A PL-3507 based CD-RW always had the following bug.  The new firewire driver stack is confirmed to be working well with this CD-RW.  The old drivers show this bug especially --- but not only --- if there is a TI PHY in the mix (TI based card or TI based hub).

The Sony PCGA-CRWD1 bundled with the Sony Vaio PCG-VX71P laptop shows the bug as a regression from 2.6.24 (Ubuntu 8.04) to 2.6.27 (Ubuntu 8.10).  The new firewire drivers have not yet been tested by the PCG-VX71P owner.  The Vaio laptop has a TI link and PHY; the SBP-2 chip in the PCGA-CRWD1 is not known.

Detailed bug info:
------------------
http://thread.gmane.org/gmane.linux.kernel.firewire.user/3519
http://thread.gmane.org/gmane.linux.kernel.firewire.user/3524

Log from Sony PCGA-CRWD1:
-------------------------
Dec  7 19:06:03 nautilus kernel: [  940.045363] ieee1394: Host added:
ID:BUS[0-00:1023]  GUID[08004603011b1622]
Dec  7 19:06:23 nautilus kernel: [  960.276097] ieee1394: The root node
is not cycle master capable; selecting a new root node and resetting...
Dec  7 19:06:25 nautilus kernel: [  961.520091] ieee1394: Error parsing
configrom for node 0-00:1023
Dec  7 19:06:25 nautilus kernel: [  962.200091] ieee1394: Error parsing
configrom for node 0-01:1023
Dec  7 19:06:26 nautilus kernel: [  962.484501] ieee1394: Node added:
ID:BUS[0-00:1023]  GUID[0800460300e06433]
Dec  7 19:06:26 nautilus kernel: [  962.485875] ieee1394: Node changed:
0-00:1023 -> 0-01:1023
Dec  7 19:06:26 nautilus kernel: [  962.488658] scsi3 : SBP-2 IEEE-1394
Dec  7 19:06:27 nautilus kernel: [  963.673100] ieee1394: unsolicited
response packet received - no tlabel match
Dec  7 19:06:47 nautilus kernel: [  983.636084] ieee1394: sbp2: Error
logging into SBP-2 device - timed out
Dec  7 19:06:47 nautilus kernel: [  983.649461] sbp2: probe of
0800460300e06433-0 failed with error -16
Dec  7 19:06:47 nautilus kernel: [  983.654663] scsi4 : SBP-2 IEEE-1394
Dec  7 19:07:08 nautilus kernel: [ 1004.656082] ieee1394: sbp2: Error
logging into SBP-2 device - timed out
Dec  7 19:07:08 nautilus kernel: [ 1004.668871] sbp2: probe of
0800460300e06433-0 failed with error -16

Log from the PL-3507 based CD-RW:
---------------------------------
Dec 13 11:41:21 stein ieee1394: Error parsing configrom for node 2-00:1023
Dec 13 11:41:21 stein ieee1394: Node changed: 2-02:1023 -> 2-03:1023
Dec 13 11:41:26 stein ieee1394: Node added: ID:BUS[2-00:1023]  GUID[0030e005003b00c8]
Dec 13 11:41:26 stein scsi54 : SBP-2 IEEE-1394
Dec 13 11:41:47 stein ieee1394: sbp2: Error logging into SBP-2 device - timed out
Dec 13 11:41:47 stein sbp2: probe of 0030e005003b00c8-0 failed with error -16
Dec 13 11:41:47 stein scsi55 : SBP-2 IEEE-1394
Dec 13 11:42:08 stein ieee1394: sbp2: Error logging into SBP-2 device - timed out
Dec 13 11:42:08 stein sbp2: probe of 0030e005003b00c8-0 failed with error -16

A successful workaround with both CD-RWs is to
  - unload the ohci1394 if already present,
  - plug in/ power on the CD-RW,
  - load ohci1394.

Another "workaround" at least with the PL-3507 based CD-RW is to use the new firewire drivers instead of the classic ieee1394 drivers.

I categorize this bug as blocker of bug 10046 although I will look into fixing it as time permits.

I categorize it as a regression even though it is only a regression with Sony PCGA-CRWD1 but not with the PL-3507 based CD-RW.
Comment 1 Stefan Richter 2008-12-16 23:49:55 UTC
Very similar downstream report:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/279342
Comment 2 Stefan Richter 2008-12-17 10:50:57 UTC
Report at https://bugs.launchpad.net/ubuntu/+source/linux/+bug/279342 is with a Western Digital My Book [...] of which the precise model is not reliably known (USB 2.0 + FireWire 400, hence /perhaps/ based on the Prolific PL-3507 IDE bridge, although WD My Book appear to be SATA nowadays) --- on an Agere FW323 controller.

My PL-3507 based CD-RW misbehaves on an Agere FW323 exactly like it does on TI controllers.  Same result:  ieee1394 + sbp2 fail as in the log in comment 0, firewire-core + firewire-sbp2 succeed.
Comment 3 Stefan Richter 2009-01-29 11:00:33 UTC
This is a subset of bug 12572.

*** This bug has been marked as a duplicate of bug 12572 ***

Note You need to log in before you can comment on or make changes to this bug.