Bug 12200 - BUG: bad unlock balance detected! e1000e
BUG: bad unlock balance detected! e1000e
Status: RESOLVED PATCH_ALREADY_AVAILABLE
Product: Drivers
Classification: Unclassified
Component: Network
All Linux
: P1 normal
Assigned To: Jeff Kirsher
:
Depends on:
Blocks: Regressions-2.6.26
  Show dependency treegraph
 
Reported: 2008-12-11 12:34 UTC by Rafael J. Wysocki
Modified: 2008-12-12 14:35 UTC (History)
2 users (show)

See Also:
Kernel Version: commit 717d438d1fde94decef874b9808379d1f4523453
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2008-12-11 12:34:40 UTC
Subject    : BUG: bad unlock balance detected! e1000e
Submitter  : "Zdenek Kabelac" <zdenek.kabelac@gmail.com>
Date       : 2008-12-08 11:24
References : http://marc.info/?l=linux-kernel&m=122873549700644&w=4
Handled-By : "Jeff Kirsher" <jeffrey.t.kirsher@intel.com>
Patch      : http://marc.info/?l=linux-kernel&m=122895597922096&w=4

This entry is being used for tracking a regression from 2.6.26.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Jeff Kirsher 2008-12-11 14:01:16 UTC
During a reset, releasing the swflag after it failed to be acquired would cause a double unlock of the mutex.  Instead, test whether acquisition of the swflag was successful and if not, do not release the swflag.  The reset must still be done to bring the device to a quiescent state.

Note You need to log in before you can comment on or make changes to this bug.